Topics

IMPORTANT NOTICE: [nginx-buildpack] End of Support for NGINX versions 1.17.x after 2020-08-07

Kashyap Vedurmudi <kvedurmudi@...>
 

The first release of the NGINX buildpack after 2020-08-07 will no longer include NGINX versions 1.17.x. These NGINX versions will no longer be supported upstream[1]. Please migrate your NGINX apps to supported versions of NGINX before that time.


Note: As 1.17.x is the current default version of NGINX in the buildpack, the default NGINX version will be updated to 1.19.x as a part of this removal. If you’d like to use a different NGINX version, please configure your application to select that version[2].


As always, the buildpacks team is happy to answer questions you may have about this deprecation in the #buildpacks Slack channel[3].


[1] - https://nginx.org/en/download.html

[2] - https://docs.cloudfoundry.org/buildpacks/nginx/index.html

[3] - https://cloudfoundry.slack.com/archives/C02HWMDUQ


Thanks,

Kashyap Vedurmudi, Buildpacks PM