Topics

CATS Migration to support CF CLI V7

Saikiran Yerram
 

Hello community friends,

With the recent CF CLI v7 release, we are migrating CATS to CF CLI v7 and also dropping support for CLI V6 in CATS. 

For contributing teams - You will have to update your pipelines to use a soon-to-be-released version of cf-deployment-concourse-task to run CATS with CLI v7. We will notify you when we ship CATS and cf-deployment-concourse-task releases. (If you're running CATS master, then your pipelines will break until you switch to the new concourse task. We recommend you pin to the last CATS version to avoid the disruption).

For Operators: Unless you're running CATS, it should not impact your workflows. We are updating smoke tests to be compatible with CLI v6 and v7. We will publish that release soon.

If you have any questions, please feel free to reach out to us in #cf-deployment or #cf-for-k8s slack channel.

Eric Promislow
 

Hello,

The PR is at https://github.com/cloudfoundry/cf-acceptance-tests/pull/423

If anyone has any concerns (or comments) on the PR, we'd appreciate if you could add them by EOD Thursday July 16.
We hope to merge it and get a new V7-based release cut by the end of the week.

Cheers,
Eric Promislow and Dave Walter, Release Integration Team