cannot access director, trying 4 more times...


Amit Kumar Gupta
 

The directory is on your computer. You probably got it by cloning the
repository from github, so only you know where you cloned it. If you are
using a unix machine, you can use the "find" utility to find directories.

On Sat, Aug 8, 2015 at 12:50 PM, Qing Gong <qinggong(a)gmail.com> wrote:

How to find out where bosh-lite directory is? I tried "which bosh" and it
shows:
/install/users/cfg/.rubies/ruby-2.1.3/bin/bosh

But that's not a directory.
Thanks.


Amit Kumar Gupta
 

Problem solved!

On Thu, Aug 13, 2015 at 12:06 PM, Qing Gong <qinggong(a)gmail.com> wrote:

The problem was that I ran the "vagrant up" outside the bosh-lite
directory so the virtual box was not bosh.

Thanks all!


Qing Gong
 

The problem was that I ran the "vagrant up" outside the bosh-lite directory so the virtual box was not bosh.

Thanks all!


Gwenn Etourneau
 

The add route script add the 10.X route the 192.X is added by
Vagrant/VirtualBox so that's mean you can reach the director without the
add-route script.

On Wed, Aug 12, 2015 at 8:00 PM, Matthew Sykes <matthew.sykes(a)gmail.com>
wrote:

Resending due to mailman issues:

Looks like you may not be doing what you think you're doing.

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox
I'm not sure where you got those commands from but they are unrelated to
bosh-lite. You're basically bringing up an Ubuntu 12.04 base box as
created by Hashicorp. The bosh-lite code isn't part of it; no director
runs in there.

You may have more luck with

$ vagrant init cloudfoundry/bosh-lite
$ vagrant up --provider virtualbox

Then you'll need to add the routes via the add-route script and use the
bosh cli to target the director in that box.

On Fri, Aug 7, 2015 at 8:21 PM, Qing Gong <qinggong(a)gmail.com> wrote:

I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM:
xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default: Warning: Connection timeout. Retrying...
default:
default: Vagrant insecure key detected. Vagrant will automatically
replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH
key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed
version of
default: VirtualBox! In most cases this is fine, but in rare cases it
can
default: prevent things such as shared folders from working properly.
If you see
default: shared folder errors, please make sure the guest additions
within the
default: virtual machine match the version of VirtualBox you have
installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.2.0
default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was
unsuccessful. I am not sure what's wrong. Searched around online and still
could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by
setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
(or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other
IP. I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong? Really appreciate any help or
guidance.

TIA!

Qing


--
Matthew Sykes
matthew.sykes(a)gmail.com


Matthew Sykes <matthew.sykes@...>
 

Resending due to mailman issues:

Looks like you may not be doing what you think you're doing.

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox
I'm not sure where you got those commands from but they are unrelated to
bosh-lite. You're basically bringing up an Ubuntu 12.04 base box as created
by Hashicorp. The bosh-lite code isn't part of it; no director runs in
there.

You may have more luck with

$ vagrant init cloudfoundry/bosh-lite
$ vagrant up --provider virtualbox

Then you'll need to add the routes via the add-route script and use
the bosh cli
to target the director in that box.

On Fri, Aug 7, 2015 at 8:21 PM, Qing Gong <qinggong(a)gmail.com> wrote:

I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM: xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default: Warning: Connection timeout. Retrying...
default:
default: Vagrant insecure key detected. Vagrant will automatically
replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH
key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed
version of
default: VirtualBox! In most cases this is fine, but in rare cases it
can
default: prevent things such as shared folders from working properly.
If you see
default: shared folder errors, please make sure the guest additions
within the
default: virtual machine match the version of VirtualBox you have
installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.2.0
default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was
unsuccessful. I am not sure what's wrong. Searched around online and still
could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by
setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
(or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other
IP. I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong? Really appreciate any help or
guidance.

TIA!

Qing


--
Matthew Sykes
matthew.sykes(a)gmail.com


Qing Gong
 

How to find out where bosh-lite directory is? I tried "which bosh" and it shows:
/install/users/cfg/.rubies/ruby-2.1.3/bin/bosh

But that's not a directory.
Thanks.


Simon D Moser
 

i had a similar problem this week, related to a VPN client that was running on my machine (that was somehow blocking the traffic) Here"s the steps that I that solved it 
 
a) reboot the box
b) after that, first run a bin/add-route from the boshlite dir
c) then do a vagrant up to bring the vm up and do a bosh target lite 
d) only then start your VPN if you need one

Mit freundlichen Grüßen / Kind regards

Simon Moser

Cloud Computing Architect
Dept. C453, IBM Research & Development Boeblingen

-------------------------------------------------------------------------------------------------------------------------------------------
IBM Deutschland
Schoenaicher Str. 220
71032 Boeblingen
Phone: +49-7031-16-4304
Fax: +49-7031-16-4890
E-Mail: smoser@...
-------------------------------------------------------------------------------------------------------------------------------------------
IBM Deutschland Research & Development GmbH / Vorsitzender des
Aufsichtsrats: Martina Koederitz
Geschäftsführung: Dirk Wittkopp
Sitz der Gesellschaft: Böblingen / Registergericht: Amtsgericht
Stuttgart, HRB 243294
 
 

----- Original message -----
From: "Qing Gong" <qinggong@...>
To: cf-dev@...
Cc:
Subject: [cf-dev] cannot access director, trying 4 more times...
Date: Fri, Aug 7, 2015 6:15 PM
 
I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM: xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Warning: Connection timeout. Retrying...
    default:
    default: Vagrant insecure key detected. Vagrant will automatically replace
    default: this with a newly generated keypair for better security.
    default:
    default: Inserting generated public key within guest...
    default: Removing insecure key from the guest if it's present...
    default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default:
    default: Guest Additions Version: 4.2.0
    default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
    default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was unsuccessful. I am not sure what's wrong. Searched around online and still could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
 (or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other IP.  I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong?  Really appreciate any help or guidance.

TIA!

Qing

 


Ronak Banka
 

Run add-route script under bin folder of bosh-lite directory.

On Aug 8, 2015 16:35, "Amit Gupta" <agupta(a)pivotal.io> wrote:

You can check to see if the director is running. From the bosh-lite
directory, you can do `vagrant ssh` and then when you're in the VM, `sudo
su -`. From there, `monit summary` will give you a summary of the
processes monit is watching, and what state they're in. You should see the
director process running, along with a handful of other processes. Are you
able to verity up to that point?

On Fri, Aug 7, 2015 at 5:05 PM, Qing Gong <qinggong(a)gmail.com> wrote:

I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM:
xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default: Warning: Connection timeout. Retrying...
default:
default: Vagrant insecure key detected. Vagrant will automatically
replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH
key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed
version of
default: VirtualBox! In most cases this is fine, but in rare cases it
can
default: prevent things such as shared folders from working properly.
If you see
default: shared folder errors, please make sure the guest additions
within the
default: virtual machine match the version of VirtualBox you have
installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.2.0
default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was
unsuccessful. I am not sure what's wrong. Searched around online and still
could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by
setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
(or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other
IP. I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong? Really appreciate any help or
guidance.

TIA!

Qing


Amit Kumar Gupta
 

You can check to see if the director is running. From the bosh-lite
directory, you can do `vagrant ssh` and then when you're in the VM, `sudo
su -`. From there, `monit summary` will give you a summary of the
processes monit is watching, and what state they're in. You should see the
director process running, along with a handful of other processes. Are you
able to verity up to that point?

On Fri, Aug 7, 2015 at 5:05 PM, Qing Gong <qinggong(a)gmail.com> wrote:

I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM: xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default: Warning: Connection timeout. Retrying...
default:
default: Vagrant insecure key detected. Vagrant will automatically
replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH
key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed
version of
default: VirtualBox! In most cases this is fine, but in rare cases it
can
default: prevent things such as shared folders from working properly.
If you see
default: shared folder errors, please make sure the guest additions
within the
default: virtual machine match the version of VirtualBox you have
installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.2.0
default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was
unsuccessful. I am not sure what's wrong. Searched around online and still
could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by
setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
(or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other
IP. I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong? Really appreciate any help or
guidance.

TIA!

Qing


Qing Gong
 

I am very new to CF. Trying to set up one using the directions here:
https://github.com/cloudfoundry/bosh-lite

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM: xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
default: Warning: Connection timeout. Retrying...
default:
default: Vagrant insecure key detected. Vagrant will automatically replace
default: this with a newly generated keypair for better security.
default:
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed version of
default: VirtualBox! In most cases this is fine, but in rare cases it can
default: prevent things such as shared folders from working properly. If you see
default: shared folder errors, please make sure the guest additions within the
default: virtual machine match the version of VirtualBox you have installed on
default: your host and reload your VM.
default:
default: Guest Additions Version: 4.2.0
default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was unsuccessful. I am not sure what's wrong. Searched around online and still could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and xip.io by setting no_proxy (xip.io is introduced later)
$ export no_proxy=192.168.50.4,xip.io
(or export no_proxy=192.168.50.4.xip.io)

$ bosh target 192.168.50.4 lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried 192.168.50.4 and a few other IP. I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong? Really appreciate any help or guidance.

TIA!

Qing