visual studio extension - login error


Vlad Iovanov
 

Glad to hear it!

Cheers,
Vlad

From: Price, Jon [mailto:jon.price(a)intel.com]
Sent: Monday, May 18, 2015 2:43 PM
To: Iovanov, Vlad Mircea; cf-dev(a)lists.cloudfoundry.org
Subject: RE: [cf-dev] visual studio extension - login error

Hi Vlad,

The new version works great! Thank you very much. :)

-- Jon

From: Iovanov, Vlad Mircea [mailto:Vlad.Iovanov(a)hp.com]
Sent: Monday, May 18, 2015 1:51 PM
To: Price, Jon; cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: RE: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please try to upgrade the Visual Studio Extensions to latest (1.2.0.4)?
We've published a new version that should address the login problems you've been experiencing. New versions of the .NET SDK and MSBuild tasks have also been published.

Cheers,
Vlad

From: Price, Jon [mailto:jon.price(a)intel.com]
Sent: Friday, May 15, 2015 11:49 AM
To: Iovanov, Vlad Mircea; cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: RE: [cf-dev] visual studio extension - login error

Hi Vlad,

We are running CF release 207.

Here is the /v2/info output with some of the data sanitized:

{"name":"vcap","build":"2222","support":"http://url.removed",
"authorization_endpoint":"https://login.paaslab3.xxx.com",
"token_endpoint":"https://uaa.paaslab3.xxx.com","min_cli_version":null,
"min_recommended_cli_version":null,"api_version":"2.25.0",
"logging_endpoint":"wss://loggregator.paaslab3.xxx.com:443"}

We normally have ldap authentication enabled and require ssl between the login server and uaa but even after disabling all of that and running with what I think is a pretty simple and standard configuration we get the error.

Thank you for taking the time to look into this.

-- Jon

From: cf-dev-bounces(a)lists.cloudfoundry.org<mailto:cf-dev-bounces(a)lists.cloudfoundry.org> [mailto:cf-dev-bounces(a)lists.cloudfoundry.org] On Behalf Of Iovanov, Vlad Mircea
Sent: Friday, May 15, 2015 10:52 AM
To: cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: Re: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Jon Price
 

Hi Vlad,

The new version works great! Thank you very much. :)

-- Jon

From: Iovanov, Vlad Mircea [mailto:Vlad.Iovanov(a)hp.com]
Sent: Monday, May 18, 2015 1:51 PM
To: Price, Jon; cf-dev(a)lists.cloudfoundry.org
Subject: RE: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please try to upgrade the Visual Studio Extensions to latest (1.2.0.4)?
We've published a new version that should address the login problems you've been experiencing. New versions of the .NET SDK and MSBuild tasks have also been published.

Cheers,
Vlad

From: Price, Jon [mailto:jon.price(a)intel.com]
Sent: Friday, May 15, 2015 11:49 AM
To: Iovanov, Vlad Mircea; cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: RE: [cf-dev] visual studio extension - login error

Hi Vlad,

We are running CF release 207.

Here is the /v2/info output with some of the data sanitized:

{"name":"vcap","build":"2222","support":"http://url.removed",
"authorization_endpoint":"https://login.paaslab3.xxx.com",
"token_endpoint":"https://uaa.paaslab3.xxx.com","min_cli_version":null,
"min_recommended_cli_version":null,"api_version":"2.25.0",
"logging_endpoint":"wss://loggregator.paaslab3.xxx.com:443"}

We normally have ldap authentication enabled and require ssl between the login server and uaa but even after disabling all of that and running with what I think is a pretty simple and standard configuration we get the error.

Thank you for taking the time to look into this.

-- Jon

From: cf-dev-bounces(a)lists.cloudfoundry.org<mailto:cf-dev-bounces(a)lists.cloudfoundry.org> [mailto:cf-dev-bounces(a)lists.cloudfoundry.org] On Behalf Of Iovanov, Vlad Mircea
Sent: Friday, May 15, 2015 10:52 AM
To: cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: Re: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Vlad Iovanov
 

Hello Jon,

Can you please try to upgrade the Visual Studio Extensions to latest (1.2.0.4)?
We've published a new version that should address the login problems you've been experiencing. New versions of the .NET SDK and MSBuild tasks have also been published.

Cheers,
Vlad

From: Price, Jon [mailto:jon.price(a)intel.com]
Sent: Friday, May 15, 2015 11:49 AM
To: Iovanov, Vlad Mircea; cf-dev(a)lists.cloudfoundry.org
Subject: RE: [cf-dev] visual studio extension - login error

Hi Vlad,

We are running CF release 207.

Here is the /v2/info output with some of the data sanitized:

{"name":"vcap","build":"2222","support":"http://url.removed",
"authorization_endpoint":"https://login.paaslab3.xxx.com",
"token_endpoint":"https://uaa.paaslab3.xxx.com","min_cli_version":null,
"min_recommended_cli_version":null,"api_version":"2.25.0",
"logging_endpoint":"wss://loggregator.paaslab3.xxx.com:443"}

We normally have ldap authentication enabled and require ssl between the login server and uaa but even after disabling all of that and running with what I think is a pretty simple and standard configuration we get the error.

Thank you for taking the time to look into this.

-- Jon

From: cf-dev-bounces(a)lists.cloudfoundry.org<mailto:cf-dev-bounces(a)lists.cloudfoundry.org> [mailto:cf-dev-bounces(a)lists.cloudfoundry.org] On Behalf Of Iovanov, Vlad Mircea
Sent: Friday, May 15, 2015 10:52 AM
To: cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: Re: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Vlad Iovanov
 

Thank you Jon, I'll test against a similar deployment and I'll let you know what I find.

Cheers,
Vlad

From: Price, Jon [mailto:jon.price(a)intel.com]
Sent: Friday, May 15, 2015 11:49 AM
To: Iovanov, Vlad Mircea; cf-dev(a)lists.cloudfoundry.org
Subject: RE: [cf-dev] visual studio extension - login error

Hi Vlad,

We are running CF release 207.

Here is the /v2/info output with some of the data sanitized:

{"name":"vcap","build":"2222","support":"http://url.removed",
"authorization_endpoint":"https://login.paaslab3.xxx.com",
"token_endpoint":"https://uaa.paaslab3.xxx.com","min_cli_version":null,
"min_recommended_cli_version":null,"api_version":"2.25.0",
"logging_endpoint":"wss://loggregator.paaslab3.xxx.com:443"}

We normally have ldap authentication enabled and require ssl between the login server and uaa but even after disabling all of that and running with what I think is a pretty simple and standard configuration we get the error.

Thank you for taking the time to look into this.

-- Jon

From: cf-dev-bounces(a)lists.cloudfoundry.org<mailto:cf-dev-bounces(a)lists.cloudfoundry.org> [mailto:cf-dev-bounces(a)lists.cloudfoundry.org] On Behalf Of Iovanov, Vlad Mircea
Sent: Friday, May 15, 2015 10:52 AM
To: cf-dev(a)lists.cloudfoundry.org<mailto:cf-dev(a)lists.cloudfoundry.org>
Subject: Re: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Jon Price
 

Hi Vlad,

We are running CF release 207.

Here is the /v2/info output with some of the data sanitized:

{"name":"vcap","build":"2222","support":"http://url.removed",
"authorization_endpoint":"https://login.paaslab3.xxx.com",
"token_endpoint":"https://uaa.paaslab3.xxx.com","min_cli_version":null,
"min_recommended_cli_version":null,"api_version":"2.25.0",
"logging_endpoint":"wss://loggregator.paaslab3.xxx.com:443"}

We normally have ldap authentication enabled and require ssl between the login server and uaa but even after disabling all of that and running with what I think is a pretty simple and standard configuration we get the error.

Thank you for taking the time to look into this.

-- Jon

From: cf-dev-bounces(a)lists.cloudfoundry.org [mailto:cf-dev-bounces(a)lists.cloudfoundry.org] On Behalf Of Iovanov, Vlad Mircea
Sent: Friday, May 15, 2015 10:52 AM
To: cf-dev(a)lists.cloudfoundry.org
Subject: Re: [cf-dev] visual studio extension - login error

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Vlad Iovanov
 

Hello Jon,

Can you please let me know what version of Cloud Foundry you are running? If you could include the output of your "info" endpoint it would be great (http://apidocs.cloudfoundry.org/208/info/get_info.html)

Cheers,
Vlad


Mike Dalessio
 

Hi Jon,

Just for context, the VS extension was only this week open-sourced by HP
and put into the CF incubator.

I expect this issue is arising because the VS extension was developed to
run with HP Helion, which has followed its own evolutionary path from a
previous version of CF, and so it has not been tested against CF edge.

As the Foundation and HP work together to incubate this project in earnest,
we'll work through these support issues and get it working with current
versions of CF.

I expect these speed bumps will get addressed quickly, and so thanks in
advance for your patience.

-m

On Thu, May 14, 2015 at 6:40 PM, Price, Jon <jon.price(a)intel.com> wrote:

We have been trying to use the visual studio extension from
https://github.com/cloudfoundry-incubator/cf-vs-extension but get an
error when logging in.



Unexpected character encountered while parsing value: <. Path “. Line 0
position 0.



The error message in the uaa logs come from the filter called
BackwardsCompatibleTokenEndpointAuthenticationFilter in the uaa code:



[2015-05-14 20:26:41.209] uaa - 14916 [http-bio-8080-exec-9] .... DEBUG
--- BackwardsCompatibleTokenEndpointAuthenticationFilter: Authentication
request for failed:
org.springframework.security.authentication.BadCredentialsException: No
client authentication found. Remember to put a filter upstream of the
TokenEndpointAuthenticationFilter.

[2015-05-14 20:26:41.211] uaa - 14916 [http-bio-8080-exec-9] .... DEBUG
--- DefaultOAuth2ExceptionRenderer: Written [error="unauthorized",
error_description="No client authentication found. Remember to put a filter
upstream of the TokenEndpointAuthenticationFilter."] as "application/json"
using
[org.springframework.http.converter.json.MappingJacksonHttpMessageConverter(a)60f269ce
]



Has anyone else tried the cf-vs-extention on their private CF environments
and have you seen this problem?





*Jon Price*

Intel Corp

_______________________________________________
cf-dev mailing list
cf-dev(a)lists.cloudfoundry.org
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev


Jon Price
 

We have been trying to use the visual studio extension from https://github.com/cloudfoundry-incubator/cf-vs-extension but get an error when logging in.

Unexpected character encountered while parsing value: <. Path “. Line 0 position 0.

The error message in the uaa logs come from the filter called BackwardsCompatibleTokenEndpointAuthenticationFilter in the uaa code:

[2015-05-14 20:26:41.209] uaa - 14916 [http-bio-8080-exec-9] .... DEBUG --- BackwardsCompatibleTokenEndpointAuthenticationFilter: Authentication request for failed: org.springframework.security.authentication.BadCredentialsException: No client authentication found. Remember to put a filter upstream of the TokenEndpointAuthenticationFilter.
[2015-05-14 20:26:41.211] uaa - 14916 [http-bio-8080-exec-9] .... DEBUG --- DefaultOAuth2ExceptionRenderer: Written [error="unauthorized", error_description="No client authentication found. Remember to put a filter upstream of the TokenEndpointAuthenticationFilter."] as "application/json" using [org.springframework.http.converter.json.MappingJacksonHttpMessageConverter(a)60f269ce]

Has anyone else tried the cf-vs-extention on their private CF environments and have you seen this problem?


Jon Price
Intel Corp