Date   

NOTICE: [go-buildpack] End of Go 1.8.x and 1.9.x support in buildpack after 2019-03-01

Elliott Shanks
 

The first release of the Go buildpack after March 1, 2019 will no longer include any versions of Go 1.8.x or 1.9.x. These Go versions are no longer supported upstream [1]. Please migrate your Go apps to supported versions of Go before that time.


Note: Unless you are manually specifying a version of Go for the buildpack to use, or you have customized your Go buildpack, no action is required.


[1] https://golang.org/doc/devel/release.html


Thanks,

Elliott Shanks, CF Buildpacks PM


Re: PostreSQL versions supported by CF

Stephan Merker
 

Thank you, Dieu.

 

@Josh: Would you document the supported PostgreSQL version range e.g. in https://github.com/cloudfoundry/cf-deployment/blob/master/deployment-guide.md#databases ?

 

Best regards,

Stephan

 

From: cf-dev@... <cf-dev@...> On Behalf Of Dieu Cao
Sent: Donnerstag, 24. Januar 2019 18:25
To: cf-dev <cf-dev@...>
Subject: Re: [cf-dev] PostreSQL versions supported by CF

 

I believe generally teams try not to make use of specialized features that necessarily require latest and greatest versions of postgresql. This is largely due to the projects wanting to support both mysql and postgres as an option.

I'm not aware of any project teams planning to make use of features that require postgres 10 or 11.

There's not an explicit minimum version across all project teams that is tested.  

 

I believe the Release Integration team is using the postgres bosh release in its pipelines, although perhaps Josh Collin and the team can confirm that.

 

Certainly if an issue crops up, the project teams can consider whether to fix it and could be considered a bug.

 

-Dieu

 

On Tue, Jan 22, 2019 at 1:04 AM Stephan Merker <stephan.merker@...> wrote:

Hello CF community,

 

with cf-deployment 6.9.0, the PostgreSQL version of the Postgres bosh release was upgraded from 9.6 to 11.

 

However, the major IaaS providers do not yet support PostgreSQL 11:

- AWS: 9.6 and 10,  11 as preview only

- GCP: 9.6

- Azure: 9.6 and 10

- Alibaba Cloud: 10

 

Do you still support PostgreSQL 9.6 and 10 for CF? Do you test cf-deployment against older PostgreSQL versions?

In case there are regressions with respect to older PostgreSQL versions: Would you regard them as bugs for the different projects contributing to cf-deployment?

 

Best regards,

Stephan

 

[1] https://github.com/cloudfoundry/cf-deployment/releases/tag/v6.9.0

[2] https://github.com/cloudfoundry/postgres-release/releases/tag/v32

 


Re: Using Imagemagick (Ghostscript) on cflinuxfs3 #cf

Markus Tanner
 

Thanks for your suggestion.
I've tried something similar already.

Unfortunately overrides only work if they are more restrictive.

The default config looks like this:
  <policy domain="coder" rights="none" pattern="PS" />
  <policy domain="coder" rights="none" pattern="PDF" />

I would need to change it to this:
  <policy domain="coder" rights="read|write" pattern="PS" />
  <policy domain="coder" rights="read|write" pattern="PDF" />

But changing the policy only works other way round, from read|write to none.
So putting the policy in ~/.magick/ unfortunately has no effect.


Re: Using Imagemagick (Ghostscript) on cflinuxfs3 #cf

Daniel Mikusa
 

This seems to indicate that ImageMagick will search in multiple locations.


When I run that on cflinuxfs3, I get..

  Searching for configure file: "/usr/share/ImageMagick-6.7.7/magic.xml"
  Searching for configure file: "/usr/lib/x86_64-linux-gnu/ImageMagick-6.7.7/config/magic.xml"
  Searching for configure file: "/etc/ImageMagick/magic.xml"
  Searching for configure file: "/usr/share/doc/ImageMagick-6.7.7/magic.xml"
  Searching for configure file: "/home/vcap/.magick/magic.xml"

I would try putting your policy file into `/home/vcap/.magick/`. That's the only path that will be writable to the vcap user.

Dan


On Wed, Jan 30, 2019 at 8:03 AM Markus Tanner <markus.tanner@...> wrote:
Hi

I'm using the nodejs-buildpack together with the cflinuxfs3 stack. I would like to convert PDF documents to JPEG images.
In order to do this I'm using Imagemagick together with Ghostscript.

cflinuxfs3 uses the following Ubuntu package: 6.9.7.4+dfsg-16ubuntu6.4
Unfortunately there's a security issue with Ghostscript in this version. Because of that the Ghostscript handled types are disabled in policy.xml.
See https://launchpad.net/ubuntu/+source/imagemagick/8:6.9.7.4+dfsg-16ubuntu6.4

I'd like to override the policy.xml (/etc/ImageMagick-6/policy.xml). 
But I would need root permissions for that, which I don't have.

Unfortunately my CF provider couldn't help me with that problem.
Does anyone here know a workaround for this?

Thanks in advance
Markus



Using Imagemagick (Ghostscript) on cflinuxfs3 #cf

Markus Tanner
 

Hi

I'm using the nodejs-buildpack together with the cflinuxfs3 stack. I would like to convert PDF documents to JPEG images.
In order to do this I'm using Imagemagick together with Ghostscript.

cflinuxfs3 uses the following Ubuntu package: 6.9.7.4+dfsg-16ubuntu6.4
Unfortunately there's a security issue with Ghostscript in this version. Because of that the Ghostscript handled types are disabled in policy.xml.
See https://launchpad.net/ubuntu/+source/imagemagick/8:6.9.7.4+dfsg-16ubuntu6.4

I'd like to override the policy.xml (/etc/ImageMagick-6/policy.xml). 
But I would need root permissions for that, which I don't have.

Unfortunately my CF provider couldn't help me with that problem.
Does anyone here know a workaround for this?

Thanks in advance
Markus



CC API v3 Proposals

Greg Cobb
 

Greetings cf-dev!

As part of the v3 acceleration initiative we announced last October, we have written a number of proposals for the remaining resources that will be exposed on the v3 API.

If you work on a project the uses the CC API, we would love your feedback on these proposals (and on your experience with the v3 API in general). Please feel free to comment on the docs, respond to this email, or message us in the #v3-acceleration-team channel on the Cloud Foundry Slack.

Here is a doc with links to all current v3 API proposals: https://docs.google.com/document/d/1g48YPBfwXT8kNrJYroBNkhlCtROe53INEEzvhQaAUOI/edit

Please keep in mind that these proposals are all under active development and will likely change as we get further along. These proposals, in addition to the v3 API documentation, can also give you perspective on what moving to the v3 APIs will look like. Look for more details about the v2 API deprecation plan coming soon.

Thanks!
V3 Acceleration Team


Re: [cf-bosh] Unconference in Philadelphia - Talks Please!

Dr Nic Williams <drnicwilliams@...>
 

Hurray for the Unconference!

Nic

 


From: cf-bosh@... on behalf of Daniel Jones <daniel.jones@...>
Sent: Thursday, January 24, 2019 10:11 am
To: Discussions about Cloud Foundry projects and the system overall.; Discussions about the Cloud Foundry BOSH project.
Subject: [cf-bosh] Unconference in Philadelphia - Talks Please!
 
Hi lovely CF peeps,

We're seeking short talk proposals for the CF Summit NA 2019 Unconference. If you've got something cool, off-the-wall, or maybe that didn't quite fit the main conference criteria, then please make a proposal! 

We want to have a couple of scheduled talks so that potential attendees have some certainty about what knowledge will be imparted upon them. Other than that, we'll be allowing plenty of time for open space discussions (more than in Basel!).

In Basel last year a whopping 20% of all summit attendees came to the Unconference, so it's a great opportunity to engage your peers in conversation and learn from each other. Whilst SAP are already sponsors, we're looking for more - so if you want a way to reach a large portion of the summit audience directly, please get in touch.

We're also bringing the Cloud Foundry Pub Quiz to North America for the first time - expect beer, rubbish jokes, obscure trivia, and lively debates about whether the questions make sense!



Regards,
Daniel 'Deejay' Jones - CTO
+44 (0)79 8000 9153
EngineerBetter Ltd - More than cloud platform specialists


Changing routing component logs to human readable timestamps

Shubha Anjur Tupil
 

Hello, 

Eric Malm (Diego) recently submitted a PR to change the log format for CF TCP Router, Route Registrar and Routing API to a more human readable format compatible with RFC 3339. I wanted to send out a note to the community to give you a heads up in case this might break integrations for some operators who might be relying on the logs and have tooling that might break from log format changes. For more details, the Diego team shared a proposal on this last year. 

Please let us know if this would break your integrations, and/or when we merge this you would need a heads up to make changes at your end. We would love to prioritize merging this subject to what we hear from the community. A few other components like container-networking have switched to this format already. Happy to answer questions or have follow ups if there are concerns. 

Regards, 
Shubha
CF Routing PM


Unconference in Philadelphia - Talks Please!

Daniel Jones
 

Hi lovely CF peeps,

We're seeking short talk proposals for the CF Summit NA 2019 Unconference. If you've got something cool, off-the-wall, or maybe that didn't quite fit the main conference criteria, then please make a proposal! 

We want to have a couple of scheduled talks so that potential attendees have some certainty about what knowledge will be imparted upon them. Other than that, we'll be allowing plenty of time for open space discussions (more than in Basel!).

In Basel last year a whopping 20% of all summit attendees came to the Unconference, so it's a great opportunity to engage your peers in conversation and learn from each other. Whilst SAP are already sponsors, we're looking for more - so if you want a way to reach a large portion of the summit audience directly, please get in touch.

We're also bringing the Cloud Foundry Pub Quiz to North America for the first time - expect beer, rubbish jokes, obscure trivia, and lively debates about whether the questions make sense!



Regards,
Daniel 'Deejay' Jones - CTO
+44 (0)79 8000 9153
EngineerBetter Ltd - More than cloud platform specialists


Re: PostreSQL versions supported by CF

Dieu Cao <dcao@...>
 

I believe generally teams try not to make use of specialized features that necessarily require latest and greatest versions of postgresql. This is largely due to the projects wanting to support both mysql and postgres as an option.
I'm not aware of any project teams planning to make use of features that require postgres 10 or 11.
There's not an explicit minimum version across all project teams that is tested.  

I believe the Release Integration team is using the postgres bosh release in its pipelines, although perhaps Josh Collin and the team can confirm that.

Certainly if an issue crops up, the project teams can consider whether to fix it and could be considered a bug.

-Dieu


On Tue, Jan 22, 2019 at 1:04 AM Stephan Merker <stephan.merker@...> wrote:

Hello CF community,

 

with cf-deployment 6.9.0, the PostgreSQL version of the Postgres bosh release was upgraded from 9.6 to 11.

 

However, the major IaaS providers do not yet support PostgreSQL 11:

- AWS: 9.6 and 10,  11 as preview only

- GCP: 9.6

- Azure: 9.6 and 10

- Alibaba Cloud: 10

 

Do you still support PostgreSQL 9.6 and 10 for CF? Do you test cf-deployment against older PostgreSQL versions?

In case there are regressions with respect to older PostgreSQL versions: Would you regard them as bugs for the different projects contributing to cf-deployment?

 

Best regards,

Stephan

 

[1] https://github.com/cloudfoundry/cf-deployment/releases/tag/v6.9.0

[2] https://github.com/cloudfoundry/postgres-release/releases/tag/v32

 


Re: MySQL service instance for Cloud Foundry #cf #service

Matt McNeeney
 

Hey,

You should check out cloudfoundry/cf-mysql-release, which is a BOSH release of a MySQL database-as-a-service for Cloud Foundry. Once deployed, you can register the Service Broker it contains with a Cloud Foundry environment and then see your MySQL service in the Cloud Foundry marketplace.

Does that look like it might help?

Matt


On Tue, 22 Jan 2019 at 15:06, <gtobon@...> wrote:
Hello Cloud Foundry community.
Does anyone know if there is a way to create or integrate a service and an instance of MySQL in Cloud Foundry?
Thank you very much friends and I remain attentive to your timely responses.


MySQL service instance for Cloud Foundry #cf #service

gtobon@...
 

Hello Cloud Foundry community.
Does anyone know if there is a way to create or integrate a service and an instance of MySQL in Cloud Foundry?
Thank you very much friends and I remain attentive to your timely responses.


Re: Help Required pcf dev installation #cf

Daniel Mikusa
 

Run `cf plugins` and see what shows up. That will list the plugin installed & the command it provides. Try removing that plugin and reinstalling cfdev.

Dan

On Sun, Jan 20, 2019 at 12:57 PM Biswa <biswamohan.padhy@...> wrote:
Hi,
I am pretty new to PCF. I am trying to install pcf dev in windows 10 pro. 
Pre-requisites for the installation are installed. But when I run the below command, Installation fails.
Command: cf install-plugin cfdev
Error: Plugin cfdev v0.0.13 could not be installed as it contains commands with names that are already used: dev.

Thanks,
Biswa


PostreSQL versions supported by CF

Stephan Merker
 

Hello CF community,

 

with cf-deployment 6.9.0, the PostgreSQL version of the Postgres bosh release was upgraded from 9.6 to 11.

 

However, the major IaaS providers do not yet support PostgreSQL 11:

- AWS: 9.6 and 10,  11 as preview only

- GCP: 9.6

- Azure: 9.6 and 10

- Alibaba Cloud: 10

 

Do you still support PostgreSQL 9.6 and 10 for CF? Do you test cf-deployment against older PostgreSQL versions?

In case there are regressions with respect to older PostgreSQL versions: Would you regard them as bugs for the different projects contributing to cf-deployment?

 

Best regards,

Stephan

 

[1] https://github.com/cloudfoundry/cf-deployment/releases/tag/v6.9.0

[2] https://github.com/cloudfoundry/postgres-release/releases/tag/v32

 


Help Required pcf dev installation #cf

Biswa
 

Hi,
I am pretty new to PCF. I am trying to install pcf dev in windows 10 pro. 
Pre-requisites for the installation are installed. But when I run the below command, Installation fails.
Command: cf install-plugin cfdev
Error: Plugin cfdev v0.0.13 could not be installed as it contains commands with names that are already used: dev.

Thanks,
Biswa


Re: apps.pushManifest behaviour is incorrect for custom private domain

Shetty, Viraj S [CTR]
 

I opened an issue today morning in the GitHub because I think its a bug. I am interested to see if there is any workaround using the Java API. Any insights? 


Re: apps.pushManifest behaviour is incorrect for custom private domain

Dieu Cao <dcao@...>
 

I see you've opened an issue on the github repo for the java client library. 
Hope that your issue is resolved there.

On Tue, Jan 15, 2019 at 3:19 PM vshetty via Lists.Cloudfoundry.Org <vshetty=fdic.gov@...> wrote:
We have developed our own implementation of zero downtime restage. We are using java client api version 3.14.0 RELEASE. As part of that

(1) we retrieve the ApplicationManifest from the old application <old name> that we need to restage using Applications.getApplicationManifest
(2) Create a new app <app name> using the Applications.pushManifest using the manifest from previous step. 
(3) Copy the bits using Applications.copySource from <old name> to <new name>

However, if I am using custom domains - then the step (2) creates a dummy app which has incorrect routes. Instead of the route being <custom domain>/<path>, the route cassociated with the new app is <app name>.<custom domain>/<path>. The <app name> is incorrectly added to the route as hostname whereas it should have been empty


Re: CF CAB call for January is this Wednesday 16th @ 8a PST

Michael Maximilien
 

Brief reminder of the first CAB call for 2019 Wednesday 16th @ 8a Pacific.

Also, if you have not taken the survey feedback for CAB calls in 2018 please take 2 mins of your time to help make the calls better:


Zoom soon. 

Best,

dr.max
ibm ☁ 
silicon valley, ca



dr.max
ibm ☁ 
silicon valley, ca


On Jan 11, 2019, at 3:41 AM, Michael Maximilien <maxim@...> wrote:

Hi, all,
 
First all HNY 2019! Hope it started well for you.

Quick reminder that the CAB call for January (first one for 2019) is next Wednesday January 16th @ 8a PST.
 
We will have our regular PMCs highlights and two talks:
 
1. Updates on the MultiApps CF-Extensions project by Nikolay Valchev of SAP [1]
2. Updates on CF Routing / Istio by Shannon Coen of Pivotal
 
All other info in agenda here [0].
 
Zoom soon. Best,
 
dr.max
ibm ☁ 
silicon valley, ca
 


apps.pushManifest behaviour is incorrect for custom private domain

Shetty, Viraj S [CTR]
 

We have developed our own implementation of zero downtime restage. We are using java client api version 3.14.0 RELEASE. As part of that

(1) we retrieve the ApplicationManifest from the old application <old name> that we need to restage using Applications.getApplicationManifest
(2) Create a new app <app name> using the Applications.pushManifest using the manifest from previous step. 
(3) Copy the bits using Applications.copySource from <old name> to <new name>

However, if I am using custom domains - then the step (2) creates a dummy app which has incorrect routes. Instead of the route being <custom domain>/<path>, the route cassociated with the new app is <app name>.<custom domain>/<path>. The <app name> is incorrectly added to the route as hostname whereas it should have been empty


Re: Mark an application instance as not ready via API

Dieu Cao <dcao@...>
 

I believe you should be able to set an http healthcheck to return 200 when your application is ready.
You could read more about that here:

-Dieu


On Tue, Jan 15, 2019 at 1:13 PM Mathias Essenpreis <mathias.essenpreis@...> wrote:

Hi,

Is it possible to tell the cloud controller via API and with this the GoRouter that a certain instance of an app is not able/ready to receive any new requests? Meaning that the GoRouter would not forward any new requests to this instance.

 

Other way round: Is it possible to remove single app instances from a route? I think it isn’t, didn’t find an API call for it.

Other way round #2: Would it be possible to give an application an application a grace time in which it will not be targeted with new requests for a period of time where it could e.g. update itself or do other housekeeping things

 

 

Regards,

Mathias

941 - 960 of 9398