IMPORTANT NOTICE: [staticfile-buildpack] End of Support for NGINX versions 1.18.x and 1.19.x after 2021-07-05


Victoria Henry <vhenry@...>
 

The first release of the Staticfile buildpack after 2021-07-05 will no longer include NGINX versions 1.18.x and 1.19.x. These NGINX versions will no longer be supported upstream[1]. Please migrate your Static content apps to supported versions of NGINX before that time.


Note: As 1.19.x is the current default version of NGINX in the buildpack, the default NGINX version will be updated to 1.20.x as a part of this removal. If you’d like to use a different NGINX version, please configure your application to select that version[2].


As always, the buildpacks team is happy to answer questions you may have about this deprecation in the #buildpacks Slack channel[3].


[1] - https://nginx.org/en/download.html

[2] - https://docs.cloudfoundry.org/buildpacks/staticfile/index.html

[3] - https://cloudfoundry.slack.com/archives/C02HWMDUQ


Thanks,

The Buildpacks Team


Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.