IMPORTANT NOTICE: [ruby-buildpack] End of Support for ruby versions 2.4.x after 2020-04-03


Kashyap Vedurmudi
 

The first release of the Ruby buildpack after 2020-04-03 will no longer include ruby versions 2.4.x. These ruby versions will no longer be supported upstream.[1] Please migrate your Ruby apps to supported versions of ruby before that time.


Note: As 2.4.x is the current default for the Ruby version in the buildpack, the default Ruby version will be updated to 2.7.x as a part of this removal. If you’d like to use a different Ruby version, please configure your application to select that version[2].


As always, the buildpacks team is happy to answer questions you may have about this deprecation in the #buildpacks Slack channel[3].


[1] - https://www.ruby-lang.org/en/news/2019/04/01/ruby-2-4-6-released/

[2] - https://docs.cloudfoundry.org/buildpacks/ruby/index.html#runtime

[3] - https://cloudfoundry.slack.com/archives/C02HWMDUQ


Thanks,

Kashyap Vedurmudi, CF Buildpacks PM


Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.