IMPORTANT NOTICE: [python-buildpack] End of support for Python versions 2.7.x after 2020-01-01


Kashyap Vedurmudi <kvedurmudi@...>
 

The first release of the Python buildpack after January 1, 2020 will no longer include Python versions 2.7.x. These Python versions will no longer be supported upstream.[1] Please migrate your Python apps to supported versions of Python before that time.


As 2.7.x is the current default for the Python version in the buildpack, the default Python version will be updated to 3.8.x as a part of this removal. If you’d like to use a different Python version, please configure your application to select that version[2]. As always, the buildpacks team is happy to answer questions you may have about this deprecation in the #buildpacks Slack channel.


Please note that as miniconda2 depends on Python 2.X, miniconda2 will also be removed as a part of this release. Miniconda3 is currently available in the buildpack.


[1] https://www.python.org/dev/peps/pep-0373/

[2] https://docs.cloudfoundry.org/buildpacks/python/index.html#runtime



Thanks,

Kashyap Vedurmudi, CF Buildpacks PM


Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.