PostreSQL versions supported by CF


Stephan Merker
 

Hello CF community,

 

with cf-deployment 6.9.0, the PostgreSQL version of the Postgres bosh release was upgraded from 9.6 to 11.

 

However, the major IaaS providers do not yet support PostgreSQL 11:

- AWS: 9.6 and 10,  11 as preview only

- GCP: 9.6

- Azure: 9.6 and 10

- Alibaba Cloud: 10

 

Do you still support PostgreSQL 9.6 and 10 for CF? Do you test cf-deployment against older PostgreSQL versions?

In case there are regressions with respect to older PostgreSQL versions: Would you regard them as bugs for the different projects contributing to cf-deployment?

 

Best regards,

Stephan

 

[1] https://github.com/cloudfoundry/cf-deployment/releases/tag/v6.9.0

[2] https://github.com/cloudfoundry/postgres-release/releases/tag/v32

 

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.