Re: bosh cf-deploy on openstack


Graham Land <info@...>
 

The attached guide shows you how to enable and verify the LBaaS service in OpenStack Pike - https://docs.openstack.org/neutron/pike/admin/config-lbaas.html

It is indeed possible to install OpenStack without enabling the LBaaS service.

Kind regards,
Graham Land

On 28 Jan 2018 6:00 am, "Russell Blue via Lists.Cloudfoundry.Org" <bluerussell20=yahoo.com@...> wrote:
Version of openstack is Pike. I have not used LBaaS. Do you need to install it??
--------------------------------------------
On Sat, 1/27/18, Graham Land <info@...> wrote:

 Subject: Re: [cf-dev] bosh cf-deploy on openstack
 To: cf-dev@...
 Date: Saturday, January 27, 2018, 4:50 PM

 From the json in the
 message body it appears to be an issue with OpenStack's
 LBaaS service.
 This service
 has had many changes in the lifetime of OpenStack from V1 to
 V2 to the Octavia project. See https://docs.openstack.org/mitaka/networking-guide/config-lbaas.html
 What version of the OpenStack LbaaS
 service is Bosh expecting? And what version are you
 deploying onto?
 Kind
 regards,Graham


 On 27 Jan 2018 10:44 am,
 "Russell Blue via Lists.Cloudfoundry.Org"
 <bluerussell20=yahoo.com@lists.cloudfoundry.org>
 wrote:
 Hi



 We have installed bosh director on openstack. When we
 execute the "Bosh cf deploy" command, about 16 VM
 successfully create only 12 cases and give the following
 errors for 4 VM.



  scheduler, router, tcp-router, smoke-test



 Error: CPI error 'Bosh::Clouds::CloudError' with
 message 'OpenStack API service not found error:
 Expected(200) <=> Actual(404 Not Found)

 excon.error.response

   :body          =>
 "{\"NeutronError\":
 {\"message\": \"The resource
 could not be found.\", \"type\":
 \"HTTPNotFound\",
 \"detail\":
 \"\"}}"







 please help me














Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.