Metron Upgrade Requirements for Services


Adam Hevenor
 

Services Developers -

Due to several changes introduced over the last year older versions of Metron will not be compatible with an upcoming version of cf-release (likely to be cf-274). If you are using a version of Loggregator < version 72 (released Dec 22, 2016) your service will not be able to communicate with Dopplers in a future cf-release. This is specifically due to Dopplers removing support for UDP transport, but also will be impacted by efforts to remove etcd as a whole from etcd. Loggregator version 72 and later will be compatible with versions of cf-release 251 and later.

Please reach out if you have questions about compatibility of Metron across specific release versions or have concerns about this upcoming change.

Thanks
Adam

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.