Re: R: Re: Deploy CF on OpenStack, api and uaa failing


Gwenn Etourneau
 

What log do you have into the dir /var/vcap/sys/log/cloudcontroller_ng/
thanks?

On Thu, Jul 9, 2015 at 8:56 PM, Michael Grifalconi <
michael.grifalconi(a)studenti.unimi.it> wrote:

Hello,

I attached the logs I got from 'bosh logs VM_JOB INSTANCE_N' and they
looks the same as the ones I can see by manually ssh into the VM.
What is the difference?


I'd point you to this logs from api, about the nfs mounter:

mount.nfs: mount(2): No such file or directory
[2015-07-09 09:24:31+0000] mount.nfs: trying 10.0.0.103 prog 100003 vers 3
prot TCP port 2049
[2015-07-09 09:24:34+0000] mount.nfs: portmap query retrying: RPC: Timed
out
[2015-07-09 09:24:34+0000] mount.nfs: trying 10.0.0.103 prog 100005 vers 3
prot TCP port 52652
[2015-07-09 09:24:36+0000] touch: cannot touch
'/var/vcap/nfs/shared/.nfs_test': Read-only file system
[2015-07-09 09:25:34+0000] stop: Unknown instance:
[2015-07-09 09:25:38+0000] umount.nfs: /var/vcap/nfs: not mounted
[2015-07-09 09:25:38+0000] umount.nfs: remote share not in 'host:dir'
format
[2015-07-09 09:25:38+0000] umount.nfs: /var/vcap/nfs: not mounted

and:

idmapd stop/waiting
[2015-07-09 09:24:28+0000] idmapd start/running, process 4862
[2015-07-09 09:24:28+0000] NFS unmounted
[2015-07-09 09:24:28+0000] Mounting NFS...
[2015-07-09 09:24:36+0000] mount.nfs: timeout set for Thu Jul 9 09:26:29
2015
[2015-07-09 09:24:36+0000] mount.nfs: trying text-based options
'timeo=10,intr,lookupcache=positive,vers=4,addr=10.0.0.103,clientaddr=10.0.0.58'
[2015-07-09 09:24:36+0000] mount.nfs: trying text-based options
'timeo=10,intr,lookupcache=positive,addr=10.0.0.103'
[2015-07-09 09:24:36+0000] mount.nfs: prog 100003, trying vers=3, prot=6
[2015-07-09 09:24:36+0000] mount.nfs: prog 100005, trying vers=3, prot=17
[2015-07-09 09:24:36+0000] mount.nfs: prog 100005, trying vers=3, prot=6
[2015-07-09 09:24:36+0000] Failed to start: cannot write to NFS
[2015-07-09 09:25:34+0000] Found NFS mount, unmounting...
[2015-07-09 09:25:34+0000] idmapd start/pre-start, process 5826
[2015-07-09 09:25:34+0000] Found NFS mount, unmounting...
[2015-07-09 09:25:38+0000] NFS unmounted
[2015-07-09 09:25:38+0000] Failed to unmount NFS, exiting...
[2015-07-09 09:27:18+0000] NFS unmounted
[2015-07-09 09:27:18+0000] idmapd start/pre-start, process 6755
[2015-07-09 09:27:18+0000] NFS unmounted
[2015-07-09 09:27:18+0000] Mounting NFS...

the manifest is on the prevuous email, I used the default manifest with
the openstack stub, after that I did some edits to solve varous errors,
like changing the default passwords for uaa and api, because they did not
match using spiff to generate the final manifest. I also added 10.0.0.0/24
instead of null on the allowed networks for nfs connections.

If I try to write in /var/vcap/nfs as root I get permission denied. If I
manually unmount and mount it back I still have no write permissions,
(strange because with null instead of 10.0.0.0/24 on allowed range, I had
permissions)

Thanks,
Michael


Il 09/07/15 12:56, *Gwenn Etourneau * <getourneau(a)pivotal.io> ha scritto:

Hi,

This log are not so usefull, can you login into the VM using bosh ssh and
go to /var/vcap/sys/log/ and you will see some folder and you will have
some log here.

thanks

On Thu, Jul 9, 2015 at 7:23 PM, Michael Grifalconi <
michael.grifalconi(a)studenti.unimi.it> wrote:

Hello all,

I'm trying to deploy CF on top of a little OpenStack cluster but I get
api and uaa VMs constantly on starting/failing status.



After each 'bosh deploy' with some changes on the configuration, I always
get:

Failed: `api_z1/0' is not running after update (00:11:07)
Error 400007: `api_z1/0' is not running after update


from api VM:
* monit summary*
*The Monit daemon 5.2.4 uptime: 7m*

*Process 'cloud_controller_ng' running*
*Process 'cloud_controller_worker_local_1' running*
*Process 'cloud_controller_worker_local_2' running*
*Process 'nginx_cc' running*
*Process 'cloud_controller_migration' running*
*Process 'routing-api' not monitored*
*Process 'metron_agent' running*
*Process 'statsd-injector' running*
*Process 'consul_agent' running*
*File 'nfs_mounter' accessible*
*System 'system_1572093d-c49a-4a38-9336-6d1a288b8bd7' running*

from uaa VM:
* monit summary*
*The Monit daemon 5.2.4 uptime: 11m*

*Process 'uaa' Connection failed*
*Process 'uaa_cf-registrar' initializing*
*Process 'metron_agent' running*
*Process 'consul_agent' running*
*System 'system_24698313-5f71-4b4f-94fc-8e09a8da0866' running*



I attach some useful info like: manifest (most probably where the error
is), and logs from uaa, nfs and api
Ps. I am using a domain that is not registered on the internet, but i
have a custom dns that resolve *.domain.co with the floating IP of the
ha_proxy (assigned manually)

Thank you!

Michael

_______________________________________________
cf-dev mailing list
cf-dev(a)lists.cloudfoundry.org
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev

------------------------------

_______________________________________________
cf-dev mailing list
cf-dev(a)lists.cloudfoundry.org
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev


_______________________________________________
cf-dev mailing list
cf-dev(a)lists.cloudfoundry.org
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.