Re: Cleaning up Cloud Controller fog dependency


Nicholas Calugar
 

Thanks for the feedback, Mike. Should have mentioned local is already on
our list: https://www.pivotaltracker.com/story/show/136137075

Wanted to bump this thread one more time to hear if there are any other fog
providers we should include in the above story?


Thanks!

Nick

--
Nicholas Calugar

On December 23, 2016 at 7:56:22 AM, Mike Youngstrom (youngm(a)gmail.com)
wrote:

Thanks Nick, we also use the "Local" provider with our enterprise NFS.

Mike

On Fri, Dec 23, 2016 at 8:47 AM, Nicholas Calugar <ncalugar(a)pivotal.io>
wrote:

Hi CF,

The Cloud Controller requires the [1] fog gem, which pulls in the entire
universe of fog providers. One of these providers has an [2] odd version
constraint because fog declares support for a lower version of ruby than
fog-google. Since Cloud Foundry ships with a specific version of ruby, we
know we can pull in a later version of fog-google, leading to an awful
situation where we have to manually add that dependency.

Our plan is to follow fog’s recommendation to require specific fog
providers instead of fog and the entire universe of providers. We’ll still
only officially support the [3] documented fog providers, but we are happy
to add any providers being used by the Cloud Foundry community.

When you have a moment, please respond with the fog provider you are using
in your deployment. We plan on making this change sometime in January once
we have a reasonable list of providers.


Thanks,

Nick


[1] https://rubygems.org/gems/fog
[2] https://github.com/fog/fog/blob/master/fog.gemspec#L63
[3] https://docs.cloudfoundry.org/deploying/common/cc-
blobstore-config.html



--
Nicholas Calugar
Product Manager - Cloud Foundry API
Pivotal Software, Inc.

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.