Re: Credentials still available to app after unbind and restage


Nicholas Calugar
 

Hi Amulya,

Could you try running "cf env <app-name>" at each step during reproduction?
If the environment variables go away when you unbind then come back the
same when you make a new binding, this points to your broker reissuing the
same credentials.

Nick

--
Nicholas Calugar
Product Manager - Cloud Foundry API
Pivotal Software, Inc.

On November 2, 2016 at 12:33:34 PM, Amulya Sharma (amulya.sharma(a)gmail.com)
wrote:

again this is on our CF deployment broker is also ours .. and app is also
ours not on PWS

On Wed, Nov 2, 2016 at 12:34 PM Amulya Sharma <amulya.sharma(a)gmail.com>
wrote:

Thanks for trying John ..
I dont think its broker issue .. or can it be ..

it may be app issue but broker is presenting right credentials .. but
this is intermittent .. I was wondering is there anything changed with
restage functionality recently

Thanks
Amulya


On Wed, Nov 2, 2016 at 12:20 PM John Feminella <jxf(a)pivotal.io> wrote:

I can't reproduce this. After restaging, the app no longer has service
instance 1's environment variables.

Which service broker is this? Could this be a bug in your service broker
where it's reusing credentials?

best,
~ jf
--
John Feminella
Advisory Platform Architect
✉ · jxf(a)pivotal.io
t · @jxxf



On Wed, Nov 2, 2016 3:15 PM, Amulya Sharma amulya.sharma(a)gmail.com wrote:

team,

we are having a unique issue of service credentials still available to
application even after unbind and restage of application.. we looked at the
app it is not storing creds anywhere .. this problem started after
migration to v243 of cloud foundry anyone else experiencing similar issue

way to reproduce
- Bind app to service instance 1
- unbind and bind to service instance 2
- restage
- app still trying to connect to service instance 1

Thanks
Amulya

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.