Re: Job `metron_agent' has invalid spec format


Marco Voelz
 

Dear Sam,

the template for metron_agent [1] is now using bosh-links [2]. That means you'll have to upgrade your BOSH Director to >=v255.5+

Hope that helps.

Warm regards
Marco

[1] https://github.com/cloudfoundry/loggregator/blob/develop/jobs/metron_agent/spec#L4
[2] http://bosh.io/docs/links.html

-----Original Message-----
From: Sam Dai <sam.dai(a)servicemax.com>
Reply-To: "Discussions about Cloud Foundry projects and the system overall." <cf-dev(a)lists.cloudfoundry.org>
Date: Tuesday 13 September 2016 at 16:44
To: "cf-dev(a)lists.cloudfoundry.org" <cf-dev(a)lists.cloudfoundry.org>
Subject: [cf-dev] Job `metron_agent' has invalid spec format

When I upload cf-release (v239 or v240 or v241) to bosh lite, always has the following error, how to resolve this error?
Started creating new jobs > loggregator_trafficcontroller/1b68e06ce4c01660b052ee10b58afd574a3aa1de. Done (00:00:00)
Started creating new jobs > metron_agent/493e00335505a6b5b9d2c6931952386e4e9616e9. Failed: Job `metron_agent' has invalid spec format: 'provides' needs to be an array of strings (00:00:00)

Error 80013: Job `metron_agent' has invalid spec format: 'provides' needs to be an array of strings

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.