Re: 404 not found: Requested route ('app.domain') does not exist. -- Worked fine this morning!

Tom Sherrod <tom.sherrod@...>

Tracked down the issue, route_emitter instance had disappeared.
bosh vms of diego deployment, did not list a route_emitter. The downloaded
manifest matched the deployment manifest, which included a route_emitter.
bosh deploy started creating the missing vm, failed because route_emitter's
ip address was taken. Deleted the instance. bosh deploy completed
Routes restored! Time to get logging in place for this environment.

Any thoughts on how/why/debugging, appreciated.

On Wed, Apr 6, 2016 at 4:10 PM, Tom Sherrod <tom.sherrod(a)> wrote:

CF 230

Developer get error above for an existing application.
I check another application, same error. I deploy a new application
successfully, same error.
bosh vms look fine. bosh cck looks fine. cf routes, yes routes are there.
No errors.

I created a new shared domain successfully. Deployed another app
specifying that domain, successful. Pull up the url and get the error in
the subject.

What happened to the existing routes? Check of the router logs show 404.
Where to look next to find out where the routes have gone??

(This is a different environment than my other issue. )


Join to automatically receive all group messages.