Re: App running even after delete. Pointers on finding it and debugging?


Tom Sherrod <tom.sherrod@...>
 

JT,

Thanks for responding.

This is a test runtime and small. I checked all orgs and spaces. No routes
matching the app.

Found the route information and the result:

{

"total_results": 0,

"total_pages": 1,

"prev_url": null,

"next_url": null,

"resources": []

}

To learn what the output may look like, I check existing routes with apps
and without. The output appears to be the same as if the app has been
deleted.

Even now, the app url still returns a page from the app, even though it is
deleted.

Thanks,

Tom

On Fri, Apr 1, 2016 at 1:52 PM, JT Archie <jarchie(a)pivotal.io> wrote:

Tom,

Are you sure the route isn't bound to another application in another
org/space?

When you do `cf routes` it only show routes for the current space. You can
hit specific API endpoints though to get all the apps for a route.

For example, `cf
curl /v2/routes/89fc2a5e-3a9b-4a88-a360-e405cdbd6f87/apps` will show all
the apps for a particular route. Obviously replacing the route ID with the
correct ID. To find that, I recommend going through `CF_TRACE=true cf
routes` and grabbing the ID.

Let see if you can hunt it down that way.

Kind Regards,

JT

On Fri, Apr 1, 2016 at 8:51 AM, Tom Sherrod <tom.sherrod(a)gmail.com> wrote:

cf 230, diego 0.1450.0, etcd 27, garden-linux 0.330.0
Default to diego true.

Developer deployed a java application. Deleted the application: cf delete
<app> No errors.
The app still responds. The only thing left is the route.
I've not encountered this before. Delete has been delete and even if
route remains, 404 Not Found: Requested route ('<hostname.domain>') does
not exist. is returned.

Pointers on tracking this down appreciated.

Tom

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.