How to deploy and bind mongodb service to nodejs application?


Vimal Mishra
 

Hi Dies,

I have deployed cf on my local machine and trying to push my nodejs application and bind mongodb services.I am using following cf version --

cf -v : cf version 6.16.1+924508c-2016-02-26

Stemcell info
-------------
Name: bosh-warden-boshlite-ubuntu-trusty-go_agent
Version: 3147

I have followed the following steps for cloud foundry deployment on local
machine :


1. Installed virtual box and vagrant.
2. wget -O spiff.zip
https://github.com/cloudfoundry-incubator/spiff/releases/download/v1.0.7/
<https://github.com/cloudfoundry-incubator/spiff/releases/download/v1.0.7/spiff_linux_amd64.zip>
3. unzip spiff.zip
4. export PATH=`pwd`:$PATH
5. git clone https://github.com/cloudfoundry/bosh-lite
6. git clone https://github.com/cloudfoundry/cf-release
7. export CF_RELEASE_DIR=`pwd`/cf-release
8. cd bosh-lite
9. bin/provision_cf
10. bin/add-routes

After these steps I am able to use cf login and create org and space.

Then I ran the command cf marketplace ,following message was displayed :

*Getting services from marketplace in org RelevanceLab / space RLCatalyst
as admin... OK No service offerings found*


So I have tried to deploy the services and followed instruction mentioned
on following link .

https://github.com/cloudfoundry-community/cf-services-contrib-release

1. bosh upload release
https://cf-contrib.s3.amazonaws.com/boshrelease-cf-services-contrib-6.tgz

2. git clone
https://github.com/cloudfoundry-community/cf-services-contrib-release.git
3. cd cf-services-contrib-release
4. git checkout v6
5. templates/make_manifest warden
6. bosh -n deploy


Then ran the command cf marketplace.It displays the same message " No service offerings found".
Can you please confirm that process followed is correct or what could be
the problem or How can I deploy services and use?

That would be great help.

Thanks
Vimal Mishra

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.