Re: abacus collector doesn't work


Hi, Jean

The root cause is that abacus takes “https” as default protocol when connect between abacus components like abacus-eureka-stub and abacus-dbserver. But in my CF env, I didn’t have any proxy server.

It may not be an issue. But I would like to have the protocol be configurable. May you consider it as an future improvement?

Thanks a lot for your and Hristo’s help!


From: Jean-Sebastien Delfino [mailto:jsdelfino(a)]
Sent: 2015年11月6日 0:15
To: Discussions about Cloud Foundry projects and the system overall.
Subject: [cf-dev] Re: Re: abacus collector doesn't work

Hi Maggie,

Which level of abacus are you using? Are you using the v0.0.2 release or a specific commit from the Abacus Github repository?

You can get a more verbose log with the following env variable:

You can set it like this:
cf set-env abacus-usage-collector DEBUG "e-abacus-*,abacus-request,abacus-router"
cf restage abacus-usage-collector

BTW, with the latest version of the Abacus master branch that DEBUG variable is already set to "e-abacus-*" (log all errors) in our default CF manifest.yml files.

Would you mind creating a Github issue including the log from the abacus-usage-collector app with the DEBUG variable set as above? We'll take a look.


- Jean-Sebastien

On Wed, Nov 4, 2015 at 7:48 PM, Meng, Xiangyi <xiangyi.meng(a)<mailto:xiangyi.meng(a)>> wrote:
Hi, Hristo

I think I am using the bosh-lite. And I tried to change the environment variable as below. But I still got the same error. Which application does collector want to connect?

dmadmin(a)dmadmin-Lenovo-Product:~/cloudfoundry/cf-abacus/cf-abacus$ cf env abacus-usage-collector
Getting env variables for app abacus-usage-collector in org test / space space as admin...

CONF: default
DEBUG: e-abacus-*
SECURED: false

dmadmin(a)dmadmin-Lenovo-Product:~/cloudfoundry/cf-abacus/cf-abacus$ cf apps
Getting apps in org test / space space as admin...

name requested state instances memory disk urls
abacus-account-stub started 1/1 512M 512M<>
abacus-usage-reporting started 1/1 512M 512M<>
abacus-usage-meter started 1/1 512M 512M<>
abacus-usage-accumulator started 1/1 512M 512M<>
abacus-dbserver started 1/1 1G 512M<>
abacus-eureka-stub started 1/1 512M 512M<>
abacus-usage-rate started 1/1 512M 512M<>
abacus-authserver-stub started 1/1 512M 512M<>
abacus-provisioning-stub started 1/1 512M 512M<>
abacus-usage-aggregator started 1/1 512M 512M<>
abacus-usage-collector started 1/1 512M 512M<>

dmadmin(a)dmadmin-Lenovo-Product:~/cloudfoundry/cf-abacus/cf-abacus$ cf security-group abacus
Getting info for security group abacus as admin

Name abacus
"destination": "<>",
"ports": "1-65535",
"protocol": "tcp"
"destination": "<>",
"ports": "1-65535",
"protocol": "udp"

Organization Space
#0 test space


Join to automatically receive all group messages.