Re: PHP extension 'gettext' doesn't work?

Daniel Mikusa

It seems to be working for me [1] (at least the extension is loading, which
usually means it'll work). Can you provide some details on what you're

- what version of PHP are you using?
- how are you enabling the extension: options.json or composer.json?
- what's the full output of `cf push`?
- what's the output of `cf logs` when you try to access a page that uses



[1] -

On Tue, Sep 29, 2015 at 3:56 AM, Hiroaki Ukaji <dt3snow.w(a)> wrote:


We deployed a php application using 'gettext' extension to manage i18n
function. (*1)

We tried to activate i18n, however, it didn't work in this php application
after all.
We also tested with a simple application which contains 'gettext', but it
seemed that the extension still doesn't work.(*2)

Is there anyone who uses i18n well by using 'gettext' extension in PHP


This result should be `/home/vcap/app/htdocs/locale: Hello, world` , if
'gettext' extension works well.


Hiroaki UKAJI

View this message in context:
Sent from the CF Dev mailing list archive at

Join to automatically receive all group messages.