Re: Issues running UAA 2.1.0+ locally and on CF


Filip Hanik
 

Good news and bad news,

bad news that you have a problem

good news is that it is happening during "./gradlew run" which means it is
easily reproducible and thus, easily fixable.

Since our Travis CI runs the embedded gradle cargo container, we can know
for certain that ./gradlew run does indeed work and the login page will be
available at http://localhost:8080/uaa/login

My first guess is that your gradle cache may contain some library that has
mutated. So, prepare yourself to download the internet and my
recommendation would be to blow away your ~/.gradle directory and try
'./gradlew run' again with the master branch

Let us know the results

Filip

On Mon, May 18, 2015 at 10:10 AM, Josh Ghiloni <jghiloni(a)ecsteam.com> wrote:

Hi all,

We recently put up CF v207 and are trying to deploy UAA into the apps
area that we use for SSO between our micro services. Before this, we’d been
running 2.0.3 with no issues. However, when I tried to upgrade to 2.2.6,
any pages we tried to hit resulted in an HTTP 404 and redirected to the
error page, which renders, though all linked stylesheets and images also
returned 404s. We reverted to 2.0.3 because we didn’t need anything in the
newer version at this time, but it’s an odd issue, and i’m wondering if
anyone else has hit it. FWIW, this also happens with ver 2.1.0, and it
happens locally (when I run `gradlew run`) as well for those versions.

Does this have anything to do with the introduction of multi-tenancy?
Any insights would be appreciated, because the logs aren’t really showing
anything. Thanks!

Josh Ghiloni
Senior Consultant
303.932.2202 o | 303.590.5427 m | 303.565.2794 f
jghiloni(a)ecsteam.com

ECS Team
Technology Solutions Delivered
ECSTeam.com






_______________________________________________
cf-dev mailing list
cf-dev(a)lists.cloudfoundry.org
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev

Join cf-dev@lists.cloudfoundry.org to automatically receive all group messages.