Re: cannot access director, trying 4 more times...

Simon D Moser

i had a similar problem this week, related to a VPN client that was running on my machine (that was somehow blocking the traffic) Here"s the steps that I that solved it 
a) reboot the box
b) after that, first run a bin/add-route from the boshlite dir
c) then do a vagrant up to bring the vm up and do a bosh target lite 
d) only then start your VPN if you need one

Mit freundlichen Grüßen / Kind regards

Simon Moser

Cloud Computing Architect
Dept. C453, IBM Research & Development Boeblingen

IBM Deutschland
Schoenaicher Str. 220
71032 Boeblingen
Phone: +49-7031-16-4304
Fax: +49-7031-16-4890
E-Mail: smoser@...
IBM Deutschland Research & Development GmbH / Vorsitzender des
Aufsichtsrats: Martina Koederitz
Geschäftsführung: Dirk Wittkopp
Sitz der Gesellschaft: Böblingen / Registergericht: Amtsgericht
Stuttgart, HRB 243294

----- Original message -----
From: "Qing Gong" <qinggong@...>
To: cf-dev@...
Subject: [cf-dev] cannot access director, trying 4 more times...
Date: Fri, Aug 7, 2015 6:15 PM
I am very new to CF. Trying to set up one using the directions here:

After running the following commands:

$ vagrant init hashicorp/precise64 (I tried both 32 and 64)
$ vagrant up --provider=virtualbox

The console shows:
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'hashicorp/precise64' is up to date...
==> default: Setting the name of the VM: xxxxxx_default_1438889867528_29074
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address:
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Warning: Connection timeout. Retrying...
    default: Vagrant insecure key detected. Vagrant will automatically replace
    default: this with a newly generated keypair for better security.
    default: Inserting generated public key within guest...
    default: Removing insecure key from the guest if it's present...
    default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default: Guest Additions Version: 4.2.0
    default: VirtualBox Version: 5.0
==> default: Mounting shared folders...
    default: /vagrant => /local/install/users/xxxxxx

Then, I tried to set the target for the bosh director but it was unsuccessful. I am not sure what's wrong. Searched around online and still could not figure out why.

I followed what's said below:
Target the BOSH Director and login with admin/admin.
# if behind a proxy, exclude both the VM's private IP and by setting no_proxy ( is introduced later)
$ export no_proxy=,
 (or export

$ bosh target lite
I always got the message shown in the subject,

cannot access director, trying 4 more times...
cannot access director, trying 3 more times...
cannot access director, trying 2 more times...

I wonder if the IP was not right. I tried and a few other IP.  I also tried to customize the IP in the Vagrantfile file.

How can I debug what's going wrong?  Really appreciate any help or guidance.




Join to automatically receive all group messages.