No progress can be seen with bosh create-env


Ushani Balasooriya
 

I found the reason. I had CF DEV VM running on my machine. When I had quit it showed me progress of downloading being done.

Finished (00:02:20)
Validating release 'bosh'... Finished (00:00:00)
Downloading release 'bosh-virtualbox-cpi'... Finished (00:02:39)
Validating release 'bosh-virtualbox-cpi'... Finished (00:00:01)
Downloading release 'bosh-warden-cpi'...
....


Ushani Balasooriya
 

Below is what I get for past few hours.

bosh create-env bosh-deployment/bosh.yml \
--state vbox/state.json \
-o bosh-deployment/virtualbox/cpi.yml \
-o bosh-deployment/virtualbox/outbound-network.yml \
-o bosh-deployment/bosh-lite.yml \
-o bosh-deployment/bosh-lite-runc.yml \
-o bosh-deployment/jumpbox-user.yml \
--vars-store vbox/creds.yml \
-v director_name="Bosh Lite Director" \
-v internal_ip=192.168.50.6 \
-v internal_gw=192.168.50.1 \
-v internal_cidr=192.168.50.0/24 \
-v outbound_network_name=NatNetwork
Deployment manifest: '/home/wso2/BOSH/bosh-deployment/bosh.yml'
Deployment state: 'vbox/state.json'

Started validating
Downloading release 'bosh'...


Ushani Balasooriya
 

When I tried to install Bosh Lite and executed the below step [2], it does not show any progress except the below [1] for few hours right now. Is it because of a network delay or anything wrong in my command? How can I know it is downloading correctly.

[1] Started validating
Downloading release 'bosh'...

[2]
$ bosh create-env ~/workspace/bosh-deployment/bosh.yml \
--state state.json \
--vars-store ./creds.yml \
-o ~/workspace/bosh-deployment/virtualbox/cpi.yml \
-o ~/workspace/bosh-deployment/virtualbox/outbound-network.yml \
-o ~/workspace/bosh-deployment/bosh-lite.yml \
-o ~/workspace/bosh-deployment/jumpbox-user.yml \
-v director_name=vbox \
-v internal_ip=192.168.56.6 \
-v internal_gw=192.168.56.1 \
-v internal_cidr=192.168.56.0/24 \
-v network_name=vboxnet0 \
-v outbound_network_name=NatNetwork