Get stuck at 96% when running "bosh upload stemcell"

Diego Lin

Hi all,

I am new for Cloud Foundry. I am trying to set up Cloud Foundry on bosh-lite to show a complete micro service solution based on Cloud Foundry.

I encounter a strange issue that the progress of uploading stemcell gets stuck at 96% when I run the command: "/home/arch/sourceCode/gSource/bosh-lite>bosh upload stemcell bosh-stemcell-3312.9-warden-boshlite-ubuntu-trusty-go_agent.tgz".

I read all I searched on the Internet, but they are helpless:

I have carefully tried several times with a common account and the root account according to the guide:
I can enter the VirtualBox VM by "ssh -p 2222 vagrant(a)" and "vagrant ssh".

It's a little urgent. I am very grateful to you for any help!

My machine is a HP PC with: i5-4570 CPU @ 3.20GHz 4 Cores, 32G memory, CentOS 7.3.

Current Settings:

1. The output of "bosh upload stemcell"(I even don't know where I can read the error log like Java App.)
/home/arch/sourceCode/gSource/bosh-lite>bosh upload stemcell bosh-stemcell-3312.9-warden-boshlite-ubuntu-trusty-go_agent.tgz
RSA 1024 bit CA certificates are loaded due to old openssl compatibility
Acting as user 'admin' on 'Bosh Lite Director'

Verifying stemcell...
File exists and readable OK
Verifying tarball...
Read tarball OK
Manifest exists OK
Stemcell image file OK
Stemcell properties OK

Stemcell info
Name: bosh-warden-boshlite-ubuntu-trusty-go_agent
Version: 3312.9

Checking if stemcell already exists...

Uploading stemcell...

bosh-stemcell: 96% |ooooooooooooooooooooooooooo | 347.4MB 39.4MB/s ETA: 00:00:00
Director task 1

Do you want to cancel task 1? [yN] (^C again to detach): ^C
bosh-stemcell: 96% |ooooooooooooooooooooooooooo | 348.2MB 269.4KB/s Time: 00:22:03
Task 1 is still running

2. The output of "vagrant --version"
[root(a)hadoopdatanode3 ~]# vagrant --version
Vagrant 1.9.1

3. The output of "VBoxManage --version"
[root(a)hadoopdatanode3 ~]# VBoxManage --version

4. The output of "vagrant up"
/home/arch/sourceCode/gSource/bosh-lite>vagrant up --provider=virtualbox
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'cloudfoundry/bosh-lite' could not be found. Attempting to find and install...
default: Box Provider: virtualbox
default: Box Version: 9000.131.0
==> default: Loading metadata for box 'cloudfoundry/bosh-lite'
default: URL:
==> default: Adding box 'cloudfoundry/bosh-lite' (v9000.131.0) for provider: virtualbox
default: Downloading:
==> default: Successfully added box 'cloudfoundry/bosh-lite' (v9000.131.0) for 'virtualbox'!
==> default: Importing base box 'cloudfoundry/bosh-lite'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'cloudfoundry/bosh-lite' is up to date...
==> default: Setting the name of the VM: bosh-lite_default_1482223891678_3283
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports...
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address:
default: SSH username: vagrant
default: SSH auth method: private key
default: Vagrant insecure key detected. Vagrant will automatically replace
default: this with a newly generated keypair for better security.
default: Inserting generated public key within guest...
default: Removing insecure key from the guest if it's present...
default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
default: The guest additions on this VM do not match the installed version of
default: VirtualBox! In most cases this is fine, but in rare cases it can
default: prevent things such as shared folders from working properly. If you see
default: shared folder errors, please make sure the guest additions within the
default: virtual machine match the version of VirtualBox you have installed on
default: your host and reload your VM.
default: Guest Additions Version: 5.0.0
default: VirtualBox Version: 5.1
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Mounting shared folders...
default: /vagrant => /home/arch/sourceCode/gSource/bosh-lite

5. The output of "route"
[root(a)hadoopdatanode3 ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default xx_core_1 UG 100 0 0 eno1
cdc04.xxxx. xx_core_1 UGH 100 0 0 eno1 bogon UG 0 0 0 vboxnet1 U 0 0 0 vboxnet1 U 0 0 0 vboxnet0 U 100 0 0 eno1

6. The output of "vagrant global-status"
[root(a)hadoopdatanode3 ~]# vagrant global-status
id name provider state directory
34b83c6 default virtualbox running /home/arch/sourceCode/gSource/bosh-lite

7. The output of "bosh status"
[root(a)hadoopdatanode3 ~]# bosh status

RSA 1024 bit CA certificates are loaded due to old openssl compatibility
Name Bosh Lite Director
Version 1.3262.3.0 (00000000)
User admin
UUID fb70f16a-4d6f-41f8-bc2e-0181a03dff18
CPI warden_cpi
dns disabled
compiled_package_cache enabled (provider: local)
snapshots disabled

Manifest /home/arch/sourceCode/gSource/cf-release/bosh-lite/deployments/cf.yml