Date   

Interpreting Bosh Version

nitin padalia
 

Hi,

One of my Bosh deployment displays directors version as:
260.0.0

However another one as:
1.3232.7.0

How to interpret them, and how can I map them with github bosh releases?

Thanks! in advance.
-nitin


Re: Errors during Start Vagrant

Danny Berger
 

Hi - welcome to Cloud Foundry! That error probably means you have an
incorrect version of Vagrant/VirtualBox installed (e.g. a version for 14.04
vs 14.10), or you're missing the correct kernel modules to use VirtualBox.
Typically the error is not related to bosh itself, so you might want to try
using VirtualBox directly to verify the installation. I'd be curious to
hear what more you find, in case others have this issue.

Danny

On Wed, Jun 28, 2017 at 7:28 AM, joao vitor da s b dos santos <
joao.santos.010(a)acad.pucrs.br> wrote:

Hello!
I'm new in this and i need deploy the Cloud Foundry using BOSH-Lite.
During the vagrant up --provider=virtualbox, i had the error below:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "4b3dc5d5-9e13-4a39-bfd2-5adf3442bf6b", "--type",
"gui"]

Stderr: VBoxManage: error: The virtual machine 'bosh-lite_default_1498657249337_96211'
has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component
MachineWrap, interface IMachine

I'm doing this using a Virtual Box Manager, not in my host.
The S.O. from VM is Ubuntu 14.04, 32 bits.

Thanks


--
Danny Berger


Errors during Start Vagrant

João Vitor Brasil <joao.santos.010 at acad.pucrs.br...>
 

Hello!
I'm new in this and i need deploy the Cloud Foundry using BOSH-Lite. During the vagrant up --provider=virtualbox, i had the error below:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "4b3dc5d5-9e13-4a39-bfd2-5adf3442bf6b", "--type", "gui"]

Stderr: VBoxManage: error: The virtual machine 'bosh-lite_default_1498657249337_96211' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

I'm doing this using a Virtual Box Manager, not in my host.
The S.O. from VM is Ubuntu 14.04, 32 bits.

Thanks


Re: [cf-dev] Re: Building cf-release using bosh cli v2

David Sabeti
 

Partha,

Like Michal suggested, you can use cf-deployment and you'll likely have an
easier time working with the BOSH v2 CLI. In the meantime, the Release
Integration team is going to look into the issues caused by using the v2
CLI against cf-release.

On Mon, Jun 12, 2017 at 6:59 AM Michal Kuratczyk <mkuratczyk(a)pivotal.io>
wrote:

Hi,

I think you'd be better off with cf-deployment - it's a new way of
deploying CF, still under development but mature enough for test
environments. It's built to be used with CLIv2:
https://github.com/cloudfoundry/cf-deployment

Best regards,

On Wed, Jun 7, 2017 at 5:13 PM, parthasarathi_kundu(a)yahoo.com <
parthasarathi_kundu(a)yahoo.com> wrote:

Folks,

Is there any way to build cf-release using bosh cli v2 .

Currently I am stuck up while running

*./scripts/generate-bosh-lite-dev-manifest*

*Unknown command `status'.*

This is obvious as bosh cli v2 does not have status command . I tried to
follow the steps from
https://github.com/cloudfoundry/cf-release/blob/master/CONTRIBUTING.md

I have deployed the bosh-lite using bosh create-env .
--
Regards Partha


--
Michal Kuratczyk | Solution Architect | Pivotal Inc.
Mobile +48602421588 <+48%20602%20421%20588> | mkuratczyk(a)pivotal.io


Re: first step with bosh

Danny Berger
 

Hi! It might be the case that VirtualBox shutdown the VM, so it's no longer
running. If so, it's probably easiest to rerun the `bosh create-env` or
`vagrant recreate` to get it back. If your VirtualBox consistently powers
off the VM, you may want to suspend the VM yourself to make sure it retains
the running BOSH processes and VMs.

Hope that helps!

Danny

On Thu, Jun 15, 2017 at 06:04 Marek Glinkowski <mglina67(a)gmail.com> wrote:

Hi :)

I need more help than request thread.
I just finish http://mariash.github.io/learn-bosh/#introduction tutorial.
I closed my Linux and when I back I have error :
Fetching info:
Performing request GET 'https://192.168.50.6:25555/info':
Performing GET request:
Retry: Get https://192.168.50.6:25555/info: dial tcp
192.168.50.6:25555: getsockopt: connection refused

Exit code 1

Could someone please help me what can I do with this error ? I am using
virtualbox-5.1
--
Danny Berger


first step with bosh

Marek Glinkowski
 

Hi :)

I need more help than request thread.
I just finish http://mariash.github.io/learn-bosh/#introduction tutorial. I closed my Linux and when I back I have error :
Fetching info:
Performing request GET 'https://192.168.50.6:25555/info':
Performing GET request:
Retry: Get https://192.168.50.6:25555/info: dial tcp 192.168.50.6:25555: getsockopt: connection refused

Exit code 1

Could someone please help me what can I do with this error ? I am using virtualbox-5.1


bosh runtime config release update question

강경원 <kyungwon.kang at samsung.com...>
 

Hi, all.

I tried to add runtime config and misconfigured something.

Can I delete or update the malfunctioning runtime addon config/script?

Already deployed addon job script is not updated although I updated the release version and runtime config.

Is it normal?

 

 
강경원(Kang, Kyungwon) Marcus Kang
RHCA/PMP/ITIL Master/OCP(Oracle/Solaris)
직급:수석
클라우드기술그룹(클라우드) M.P: 82-10-8998-2092
kyungwon.kang@...
 

 


Re: Building cf-release using bosh cli v2

Michal Kuratczyk
 

Hi,

I think you'd be better off with cf-deployment - it's a new way of
deploying CF, still under development but mature enough for test
environments. It's built to be used with CLIv2:
https://github.com/cloudfoundry/cf-deployment

Best regards,

On Wed, Jun 7, 2017 at 5:13 PM, parthasarathi_kundu(a)yahoo.com <
parthasarathi_kundu(a)yahoo.com> wrote:

Folks,

Is there any way to build cf-release using bosh cli v2 .

Currently I am stuck up while running

*./scripts/generate-bosh-lite-dev-manifest*

*Unknown command `status'.*

This is obvious as bosh cli v2 does not have status command . I tried to
follow the steps from https://github.com/cloudfoundry/cf-release/blob/
master/CONTRIBUTING.md

I have deployed the bosh-lite using bosh create-env .
--
Regards Partha


--
Michal Kuratczyk | Solution Architect | Pivotal Inc.
Mobile +48602421588 | mkuratczyk(a)pivotal.io


Building cf-release using bosh cli v2

PARTHASARATHI KUNDU
 

Folks,

Is there any way to build cf-release using bosh cli v2 .

Currently I am stuck up while running

*./scripts/generate-bosh-lite-dev-manifest*

*Unknown command `status'.*

This is obvious as bosh cli v2 does not have status command . I tried
to follow the steps from
https://github.com/cloudfoundry/cf-release/blob/master/CONTRIBUTING.md

I have deployed the bosh-lite using bosh create-env .

--
Regards Partha


Re: BOSH service deploy throwing CPI error

Riegger, Felix
 

Hi Subin,

it appears, that the network ID given in your BOSH OpenStack CPI config does not exist in the (also configured) OpenStack project the CPI is running against. Like the error message states, it is important to specify the network id and not the subnet id, which would be the more intuitive thing to do. Please double check network ids and project id and try again.

Kind regards,
Felix

On 19.05.17, 15:57, "subin alex" <alexkutty19(a)gmail.com> wrote:

Hi Experts,

I am trying to deploy an enterprise application on Openstack instance jumpbox.I have BOSH and CloudFoundry already setup and is working fine.However ,while i am deploying my application services to BOSH,I am getting below error,

Failed: CPI error 'Bosh::Clouds::VMCreationFailed' with message 'VM creation with name 'ZZZZ' failed. Following network IDs are not existing or not accessible from this project: 'XXXX'. Make sure you do not use subnet IDs' in 'create_vm' CPI method (00:00:02)

From the error message,it looks likean issue wherein BOSH is prevented from creating VMs on configured floating IPs on the instance(with id 'XXXX').

But I am unable to narrow down as to where is the exact problem lying.

Can you guys please help me out on this?

Thanks & Regards,
Subin


Spiff is not working to create deployment manifest file

Kumaresh Babu
 

I installed spiff using gvm in AWS Ubuntu VM. When I try with spiff -v, it shows me the version of spiff.
ubuntu(a)agent-id-bosh-0:~/cf-release$ spiff -v
spiff version 1.0.8

Spiff CLI is working fine. But the problem is to generate bosh-lite-dev-manifest using spiff.

ubuntu(a)agent-id-bosh-0:~/cf-release$ sudo ./scripts/generate-bosh-lite-dev-manifest
RSA 1024 bit CA certificates are loaded due to old openssl compatibility
RSA 1024 bit CA certificates are loaded due to old openssl compatibility
Aborted. Please install spiff by following https://github.com/cloudfoundry-incubator/spiff#installation

Do I need set path for Spiff in AWS Ubuntu Instance? If yes, how to set path for Spiff?

Please help me!!!


Re: Edit/delete a post

James Leavers
 

I wonder how many people have gone to look for the original email now :-)

On 31 May 2017 at 16:40:11, Chip Childers (cchilders(a)cloudfoundry.org)
wrote:

There is no facility to do that, although it would be largely ineffective
anyway. Your message went out to all subscribers on this mailing list
already.

On Wed, May 31, 2017 at 11:29 AM kieran robinson <kieran.robinson7(a)gmail.com>
wrote:

Hi guys,

I just recently made a post however I included a URL which I would like to
be deleted, can this please be done?

Do I have access to do this?

Thanks
--
Chip Childers
CTO, Cloud Foundry Foundation
1.267.250.0815


Re: Edit/delete a post

Chip Childers
 

There is no facility to do that, although it would be largely ineffective
anyway. Your message went out to all subscribers on this mailing list
already.

On Wed, May 31, 2017 at 11:29 AM kieran robinson <kieran.robinson7(a)gmail.com>
wrote:

Hi guys,

I just recently made a post however I included a URL which I would like to
be deleted, can this please be done?

Do I have access to do this?

Thanks
--
Chip Childers
CTO, Cloud Foundry Foundation
1.267.250.0815


Edit/delete a post

kieran robinson
 

Hi guys,

I just recently made a post however I included a URL which I would like to
be deleted, can this please be done?

Do I have access to do this?

Thanks


Re: logsearch-for-cloudfoundry instance failing

Josh Ghiloni
 

This should probably be in cf-dev, but I will say that the first error looks like your user/client does not have the `doppler.firehose` scope in its credentials. As for the second error, looks like the logsearch vm could not verify the whole cert chain of your SSL cert. (Clearing up the second may clear up the first)

--
Josh Ghiloni | ECS Team, now part of CGI | Senior Cloud Architect
5575 DTC Parkway Suite 135, Greenwood Village, CO 80111
T: (303) 590-5427
jghiloni(a)ecsteam.com | www.cgi.com <http://www.cgi.com> | www.ecsteam.com <http://www.ecsteam.com>

On 5/31/17, 8:53 AM, "Kieran Robinson" <kieran.robinson7(a)gmail.com> wrote:

Hey Guys,

We have been having an issue when trying to deploy logsearch, all VM’s are running within CF and all instances running for log search except `logsearch-for-cloudfoundry` which is failing. We have been unable to figure out this issue after troubleshooting for a few days. I was wondering if anyone else ran into similar issues or would have any guidance on possible solutions.

I have included two logs below, one from the instance which is failing `logsearch-for-cloudfoundry` and the second from the log-api instance running in CF

From logsearch-for-cloudfoundry

```
Exception occurred! Message: Closing connection with traffic controller due to error Details: Error dialing trafficcontroller server: Unauthorized error: You are not authorized. Error: Invalid authorization.
```

From traffic controller

```
Error getting auth data: Post https://uaa.cf.prod-infra.gl1.allstate.com/check_token: remote error: tls: handshake failure
```


logsearch-for-cloudfoundry instance failing

kieran robinson
 

Hey Guys,

We have been having an issue when trying to deploy logsearch, all VM’s are running within CF and all instances running for log search except `logsearch-for-cloudfoundry` which is failing. We have been unable to figure out this issue after troubleshooting for a few days. I was wondering if anyone else ran into similar issues or would have any guidance on possible solutions.

I have included two logs below, one from the instance which is failing `logsearch-for-cloudfoundry` and the second from the log-api instance running in CF

From logsearch-for-cloudfoundry

```
Exception occurred! Message: Closing connection with traffic controller due to error Details: Error dialing trafficcontroller server: Unauthorized error: You are not authorized. Error: Invalid authorization.
```

From traffic controller

```
Error getting auth data: Post https://uaa.cf.prod-infra.gl1.allstate.com/check_token: remote error: tls: handshake failure
```


Re: Proposal: Rename disk_types.cloud_properties.type

Evan Farrar <evanfarrar@...>
 

That new error message is an excellent idea, as it addresses the specific
confusion I have witnessed and it leads the user to a resolution in fewer
steps than my proposal outlines.

On Thu, May 25, 2017 at 7:08 PM, Danny Berger <dberger(a)pivotal.io> wrote:

I agree this could be a bit confusing to both newcomers and others. I'm
not sure renaming the `disk_types.cloud_properties.type` is the correct
solution though. The values in `cloud_properties` should be values which
make sense and are native to the IaaS, so they'll all follow slightly
different conventions and should probably be more consistent to the IaaS
context than a BOSH context. VM types could have a similar discussion.

The persistent_disk_type/disk_types/disk_pool confusion should hopefully
pass with time as everyone consolidates on cloud-config-type manifests.

As a compromise to at least help give the user a better hint, I wonder if
director could say something like `Persistent disk "default" not found
(expected "small", "large", "large_gp2")`.

On Thu, May 18, 2017 at 12:12 PM, Evan Farrar <evanfarrar(a)gmail.com>
wrote:

After helping a BOSH Bootloader user today with deploying a BOSH release
I've realized that there is a small pain point in the BOSH cloud-config
schema that could be resolved.

I suggest we disambiguate the schema and terminology used within BOSH
regarding disk types. There are three closely related things that all
re-use the term “type”: persistent_disk_type, disk_types, and
disk_types.cloud_properties.type. This is a recent issue, because
previously disk_pool was renamed to disk_type to clarify the
relationship between persistent_disk_type and disk_pool.

Problem: A user receives an error message like “Persistent disk
“default” not found.” She must consult her cloud-config for an
acceptable disk type to substitute and may be led to believe that “S4” or
“gp2” would be an acceptable value when in fact the persistent_disk_type
field requires a value from disk_types.name.

Solution: Renaming disk_types.cloud_properties.type to
disk_types.cloud_properties.storage. I have based this on the
terminology used on IaaS pricing documentation, where most use the term
“volume type” or “volume storage” for this piece of information.

I'm curious what others think of this proposal. Please add comments and
suggestions on this document
<https://docs.google.com/document/d/1VpWLtVWOF38Y65WY7Zpqd2qLKYfzE4CkdlufsqbLBbA/edit?usp=sharing>[1]
or via mailing list.


[1] https://docs.google.com/document/d/1VpWLtVWOF38Y65WY7Zpqd2qL
KYfzE4CkdlufsqbLBbA/edit?usp=sharing


--
Danny Berger


Re: BOSH CPI for Alibaba

Gunakar Rao
 

Hello Gwenn,

Thanks for info. Yes for contribution , i see the opportunity

Thanks


Re: BOSH CPI for Alibaba

Gwenn Etourneau
 

No as far as I know, I don't think there is a CPI for Alibaba.

But it's a good chance for you to contribute to the community.

Thanks

On Mon, May 29, 2017 at 6:17 PM, Gunakar Rao <gunakarp(a)gmail.com> wrote:

Hello Team,

Any pointers , if BOSH CPI available for Alibaba cloud !!

From official doc[https://bosh.io/docs/build-cpi.html], I can see AWS
,Azure ,OpenStack ,vSphere ,vCloud CPI release .

In terms of development , SDK from alibaba is also available.
There is a ref here, not much progress since 2 years.

Thanks
Gunakar


BOSH CPI for Alibaba

Gunakar Rao
 

Hello Team,

Any pointers , if BOSH CPI available for Alibaba cloud !!

From official doc[https://bosh.io/docs/build-cpi.html], I can see AWS
,Azure ,OpenStack ,vSphere ,vCloud CPI release .

In terms of development , SDK from alibaba is also available.
There is a ref here, not much progress since 2 years.

Thanks
Gunakar

521 - 540 of 2761