Error: Public uaa token must be PEM encoded


JOSE FELIX HERNANDEZ BARRIO
 

Hi,

I'm trying to deploy cloudfoundry on openstack. I'm getting stuck at bosh deploy.

The result from bosh vms:

+------------------------------------+---------+---------------+---------------+
| Job/index | State | Resource Pool | IPs |
+------------------------------------+---------+---------------+---------------+
| api_worker_z1/0 | running | small_z1 | 10.2.0.105 |
| api_z1/0 | failing | large_z1 | 10.2.0.103 |
| clock_global/0 | running | medium_z1 | 10.2.0.104 |
| doppler_z1/0 | running | medium_z1 | 10.2.0.108 |
| etcd_z1/0 | running | medium_z1 | 10.2.0.58 |
| ha_proxy_z1/0 | running | router_z1 | 10.2.0.50 |
| | | | 192.168.1.203 |
| hm9000_z1/0 | running | medium_z1 | 10.2.0.106 |
| loggregator_trafficcontroller_z1/0 | running | small_z1 | 10.2.0.109 |
| nats_z1/0 | running | medium_z1 | 10.2.0.52 |
| nfs_z1/0 | running | medium_z1 | 10.2.0.53 |
| postgres_z1/0 | running | medium_z1 | 10.2.0.54 |
| router_z1/0 | running | router_z1 | 10.2.0.55 |
| runner_z1/0 | running | runner_z1 | 10.2.0.107 |
| stats_z1/0 | running | small_z1 | 10.2.0.101 |
| uaa_z1/0 | running | medium_z1 | 10.2.0.102 |
+------------------------------------+---------+---------------+---------------+


So i check monit summary at api_z1:

Process 'cloud_controller_ng' running
Process 'cloud_controller_worker_local_1' running
Process 'cloud_controller_worker_local_2' running
Process 'nginx_cc' running
Process 'cloud_controller_migration' running
Process 'routing-api' not monitored
Process 'metron_agent' running
Process 'statsd-injector' running
Process 'consul_agent' running
File 'nfs_mounter' accessible
System 'system_10391701-0eec-4e27-916b-5b9d95f86cbc' runnin


Then i check the log file /var/vcap/sys/log/routing-api/routing-api.log and it has the message:
{"timestamp":"1441587481.040446758","source":"routing-api","message":"routing-api.failed to check public token","log_level":2,"data":{"error":"Public uaa token must be PEM encoded"}}


what am i doing wrong in my cf-deployment.yml?

my cf-deployment.yml https://gist.github.com/josefhernandez/0f022c38f25539f9db7b



Best regards

Join cf-bosh@lists.cloudfoundry.org to automatically receive all group messages.