Re: cf api connection refused?


Kris Rice
 

curl doesn’t appear to be in there. Here’s the route table and a wget which is the same connection refused.

vagrant(a)bosh-lite:~$ !wget
wget https://api.10.244.0.134.xip.io/v2/info
--2015-08-25 18:28:37-- https://api.10.244.0.134.xip.io/v2/info
Resolving api.10.244.0.134.xip.io (api.10.244.0.134.xip.io)... 10.244.0.134, 10.244.0.134
Connecting to api.10.244.0.134.xip.io (api.10.244.0.134.xip.io)|10.244.0.134|:443... failed: Connection refused.
Connecting to api.10.244.0.134.xip.io (api.10.244.0.134.xip.io)|10.244.0.134|:443... failed: Connection refused.


vagrant(a)bosh-lite:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.0.2.2 0.0.0.0 UG 0 0 0 eth0
10.0.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
10.244.0.4 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcf-0
10.244.0.20 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcl-0
10.244.0.24 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckck-0
10.244.0.28 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckci-0
10.244.0.32 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckch-0
10.244.0.40 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcb-0
10.244.0.128 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcc-0
10.244.0.132 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckce-0
10.244.0.136 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcg-0
10.244.0.140 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcd-0
10.244.0.144 0.0.0.0 255.255.255.252 U 0 0 0 wvdupqknckcj-0
192.168.50.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

and btw thanks for the help !

-kris

On Aug 25, 2015, at 14:25, Dmitriy Kalinin <dkalinin(a)pivotal.io> wrote:

can you `vagrant ssh` and run `curl -k https://api <https://api/>.10.244.0.134.xip.io/v2/info <http://10.244.0.134.xip.io/v2/info>`?

On Tue, Aug 25, 2015 at 11:17 AM, kris rice <kris.rice(a)jokr.net <mailto:kris.rice(a)jokr.net>> wrote:
It shows all good. I can ssh into the api machine with no problems.


└─>bosh vms
Acting as user 'admin' on 'Bosh Lite Director'
Deployment `cf-warden'

Director task 18

Task 18 done

+------------------------------------+---------+---------------+--------------+
| Job/index | State | Resource Pool | IPs |
+------------------------------------+---------+---------------+--------------+
| api_z1/0 | running | large_z1 | 10.244.0.134 |
| doppler_z1/0 | running | medium_z1 | 10.244.0.142 |
| etcd_z1/0 | running | medium_z1 | 10.244.0.42 |
| ha_proxy_z1/0 | running | router_z1 | 10.244.0.34 |
| hm9000_z1/0 | running | medium_z1 | 10.244.0.138 |
| loggregator_trafficcontroller_z1/0 | running | small_z1 | 10.244.0.146 |
| nats_z1/0 | running | medium_z1 | 10.244.0.6 |
| postgres_z1/0 | running | medium_z1 | 10.244.0.30 |
| router_z1/0 | running | router_z1 | 10.244.0.22 |
| runner_z1/0 | running | runner_z1 | 10.244.0.26 |
| uaa_z1/0 | running | medium_z1 | 10.244.0.130 |
+------------------------------------+---------+---------------+--------------+

VMs total: 11

On Aug 25, 2015, at 14:15, Dmitriy Kalinin <dkalinin(a)pivotal.io <mailto:dkalinin(a)pivotal.io>> wrote:

what does your `bosh vms` show?

On Tue, Aug 25, 2015 at 10:21 AM, kris rice <kris.rice(a)jokr.net <mailto:kris.rice(a)jokr.net>> wrote:
Seems a combination of the 215 release and the patches Vbox let’s me finally have a setup running more than ~10 minutes. So I have a clean install from this morning. Now I get a connection refused

└─>cf api https://api.10.244.0.134.xip.io/ <https://api.10.244.0.134.xip.io/>
Setting api endpoint to https://api.10.244.0.134.xip.io/. <https://api.10.244.0.134.xip.io/>..
FAILED
Error performing request: Get https://api.10.244.0.134.xip.io/v2/info <https://api.10.244.0.134.xip.io/v2/info>: dial tcp 10.244.0.134:443 <http://10.244.0.134:443/>: connection refused


I added the route changes and verified the traceroute is going to the proper place thru the vbox.

Any suggestions to check on ?

-kris

Join cf-bosh@lists.cloudfoundry.org to automatically receive all group messages.