Re: bosh micro deploy stuck at Started deploy micro bosh > Waiting for the agent

Dulanjalie Dhanapala <dulanjalie@...>

Hi Gwenn,
I do not see any error in my sg settings. Still the issue is there. I
brought up a VM manually then I was able to SSH to it. So i believe key is

TypeProtocolPort RangeSourceCustom TCP RuleTCP6868<IP of the VM I run
TCP RuleTCP25555<IP of the VM I run BOSH>
SSHTCP22<IP of the VM I run BOSH>
All TCPTCP0-65535SG itselfAll UDPUDP0-65535SG itself


On Mon, Jun 15, 2015 at 6:25 PM, Gwenn Etourneau <getourneau(a)>

Please check security groups on AWS
Can be a communication issue between director and the bosh agent.

On Tue, Jun 16, 2015 at 8:10 AM, Dulanjalie Dhanapala <
dulanjalie(a)> wrote:

Hi all,
I am in the process of bringing up cloud foundry setup using BOSH for the
first time.

when i execute bosh micro deploy it got stuck at below point. I see a Vm
got created in AWS. I am not aware of which log file that i should check.
Please let me know how I can debug this?


cfoundry(a)c-foundry:~/micro-deployment$ bosh micro deploy

No `bosh-deployments.yml` file found in current directory.

Conventionally, `bosh-deployments.yml` should be saved in /home/cfoundry.

Is /home/cfoundry/micro-deployment a directory where you can save state?
(type 'yes' to continue): yes

Deploying new micro BOSH instance `manifest.yml' to `https://<VIP
IP>:25555' (type 'yes' to continue): yes

Verifying stemcell...

File exists and readable OK

Verifying tarball...

Read tarball OK

Manifest exists OK

Stemcell image file OK

Stemcell properties OK

Stemcell info


Name: bosh-aws-xen-hvm-ubuntu-trusty-go_agent

Version: 2986

Started deploy micro bosh

Started deploy micro bosh > Unpacking stemcell. Done (00:00:00)

Started deploy micro bosh > Uploading stemcell. Done (00:00:09)

Started deploy micro bosh > Creating VM from ami-3742b55c light. Done

Started deploy micro bosh > Waiting for the agent

cf-bosh mailing list

cf-bosh mailing list


Join { to automatically receive all group messages.