bosh-gen v0.93 - continuing to move forward to `bosh` v2 support


Dr Nic Williams
 

bosh-gen is getting closer to v1.0. For five years it has been the most
awesome tool for creating new BOSH releases, extracting packages and jobs
from other releases, and more.

Today it adds the following bosh2 improvements:


- extract-job and extract-pkg commands use bosh add-blob for blobs
- extract-job and extract-pkg commands correctly glob for many files
across both src/ and blobs/ directories
- If bosh2 is installed then it is used; else assumes bosh is the latest
bosh2 CLI
- gem install bosh-gen will no longer install old bosh_cli gem and its
old bosh CLI.

To upgrade:

gem install bosh-gen
gem uninstall bosh_cli # whilst you're in the mood for cleaning up


--
Dr Nic Williams
Stark & Wayne LLC
http://starkandwayne.com
+61 437 276 076
twitter @drnic

Join cf-bosh@lists.cloudfoundry.org to automatically receive all group messages.