bosh director via http proxy


Daniel Hermans <daniel.hermans@...>
 

Hi,
attempting to start a bosh deployment. My work machine uses a http proxy for internet access. I have set http_proxy and https_proxy variables in the shell but getting stuck. Am i missing something?

I can see bosh attempting to do direct network connections to AWS rather than use the proxy:
$ netstat -tn
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 1 10.39.224.104:36468 54.240.195.243:443 SYN_SENT


Error message from bosh create-env:

$ bosh create-env bosh-deployment/bosh.yml --state=state.json --vars-store=creds.yml -o bosh-deployment/aws/cpi.yml -v director_name=bosh-1 ...........


Started validating
Downloading release 'bosh'... Skipped [Found in local cache] (00:00:00)
Validating release 'bosh'... Finished (00:00:01)
Downloading release 'bosh-aws-cpi'... Skipped [Found in local cache] (00:00:00)
Validating release 'bosh-aws-cpi'... Finished (00:00:00)
Validating cpi release... Finished (00:00:00)
Validating deployment manifest... Finished (00:00:00)
Downloading stemcell... Skipped [Found in local cache] (00:00:00)
Validating stemcell... Finished (00:00:00)
Finished validating (00:00:01)

Started installing CPI
Compiling package 'ruby_aws_cpi/c6ba8a1e1b53b94ee9caf13d2d749c40cecfa038'... Finished (00:00:00)
Compiling package 'bosh_aws_cpi/137cfc70652337ff1d3fca795e6d9ddd6e7e68dd'... Finished (00:00:00)
Installing packages... Finished (00:00:00)
Rendering job templates... Finished (00:00:00)
Installing job 'aws_cpi'... Finished (00:00:00)
Finished installing CPI (00:00:00)

Starting registry... Finished (00:00:00)
Uploading stemcell 'bosh-aws-xen-hvm-ubuntu-trusty-go_agent/3421.9'... Failed (00:03:36)
Stopping registry... Finished (00:00:00)
Cleaning up rendered CPI jobs... Finished (00:00:00)

creating stemcell (bosh-aws-xen-hvm-ubuntu-trusty-go_agent 3421.9):
CPI 'create_stemcell' method responded with error: CmdError{"type":"Bosh::Clouds::CloudError","message":"Unable to create a connection to AWS. Please check your provided settings: Region 'ap-southeast-2', Endpoint 'Not provided'.\nIaaS Error: #\u003cSeahorse::Client::NetworkingError: execution expired\u003e","ok_to_retry":false}

Exit code 1


Any help appreciated...

Thanks!

Join cf-bosh@lists.cloudfoundry.org to automatically receive all group messages.