Re: Create bosh stemcell failed in AWS region cn-north-1

王小锋 <zzuwxf at>

Hi, Wayne

I also met the same issue as 支雷, could you please let us know how to create
custom stemcell? Is there any guide? thanks a lot.

2015-06-01 20:23 GMT+08:00 Wayne E. Seguin <wayneeseguin(a)>:


Have you tried creating your own custom stemcell yet while you wait?


On Fri, May 29, 2015 at 5:18 AM, 支雷 <lzhi3937(a)> wrote:

I have been blocked by this issue for two weeks, and have no progress. I
am looking forward to you to solve this problem. Thanks a lot.

2015-05-27 9:11 GMT+08:00 Dmitriy Kalinin <dkalinin(a)>:

It seems like this method cannot find appropriate AKIs:

I just requested account from AWS to access China region and try to
reproduce the problem.

On Wed, May 20, 2015 at 8:37 PM, Dr Nic Williams <
drnicwilliams(a)> wrote:

There are two issues - the second is that bosh-bootstrap uses a project
"cyoi" (choose your own infrastructure) and underneath it uses "fog" - its
quite possible that either or both do not yet support China (its harder to
get accounts to do testing).

The former is failing inside AWS SDK for Ruby.

BOSH calls into this library here:

We are using aws-sdk (= 1.60.2)

The latest version is 2.0.42

So perhaps China support was added more recently and we need to bump to
newer aws-sdk version.

Try bumping this version in the Gemfile of bosh and using that.

Avoid bosh-bootstrap until you've at least confimed you can get
underlying bosh_cli to work.

On Wed, May 20, 2015 at 8:17 PM, 支雷 <lzhi3937(a)> wrote:

I have tried full stemcell
bosh-stemcell-2972-aws-xen-ubuntu-trusty-go_agent.tgz, but failed, error
"create stemcell failed: unable to find AKI:" was thrown (please find
details in my first email). And when I tried to "bosh-bootstrap deploy"
command, I got `validate_aws_region': Unknown region: "cn-north-1"
(ArgumentError). Seems cn-north-1 is not supported by bosh aws plugin. Any
suggestions on this issue? Thanks!

2015-05-19 23:58 GMT+08:00 Wayne E. Seguin <

The issue is that there appear to not be any light stemcells in your
region, there is another recent question on the list to this effect. In
order to make progress you might want to build your own stemcell to use for
now or try to find and download a full aws hvm stemcell image to upload.

On Mon, May 18, 2015 at 6:12 AM, 支雷 <lzhi3937(a)> wrote:


I tried to deploy micro bosh in AWS region cn-north-1 in several
ways, but all failed. Any suggestions on how to deploy micro bosh in AWS
region cn-north-1? Thanks!

I created a EC2 instance (ubuntu) in the cn-north-1 region with an
public ip, ssh'd into it and installed bosh-cli, bosh_cli_plugin_micro and
bosh_cli_plugin_aws. After that I downloaded stemcell
bosh-stemcell-2972-aws-xen-ubuntu-trusty-go_agent.tgz, and tried " bosh
micro deploy ./bosh-stemcell-2972-aws-xen-ubuntu-trusty-go_agent.tgz" which
resulted in "create stemcell failed: getaddrinfo: Name or service not

I checked the failed URL, it's "" which
is not accessable. I updated the http.rb and changed the url to "" and escape the ssl validation and
tried again, another error was thrown:

Stemcell info
Name: bosh-aws-xen-ubuntu-trusty-go_agent
Version: 2972

Started deploy micro bosh
Started deploy micro bosh > Unpacking stemcell. Done (00:00:08)
Started deploy micro bosh > Uploading stemcell"
create stemcell failed: unable to find AKI:
`block in create_stemcell'
`block (2 levels) in create_stemcell'
`block in create_stemcell'
/usr/lib/ruby/1.9.1/tmpdir.rb:83:in `mktmpdir'
`block in create_deployment'
/var/lib/gems/1.9.1/gems/bosh_cli-1.2972.0/bin/bosh:16:in `<top
/usr/local/bin/bosh:23:in `load'
/usr/local/bin/bosh:23:in `<main>'

After that I installed bosh-bootstrap and executed following command:

bosh-bootstrap deploy

and I selected AWS provider and region 10 (China (Beijing) Region
(cn-north-1)), an error was thrown :

Confirming: Using AWS EC2/cn-north-1
`validate_aws_region': Unknown region: "cn-north-1" (ArgumentError)
/var/lib/gems/1.9.1/gems/fog-core-1.30.0/lib/fog/compute.rb:60:in `new'
/var/lib/gems/1.9.1/gems/cyoi-0.11.3/lib/cyoi/providers.rb:17:in `new'
/var/lib/gems/1.9.1/gems/thor-0.19.1/lib/thor/command.rb:27:in `run'
from /var/lib/gems/1.9.1/gems/thor-0.19.1/lib/thor.rb:359:in
/var/lib/gems/1.9.1/gems/thor-0.19.1/lib/thor/base.rb:440:in `start'
`<top (required)>'
from /usr/local/bin/bosh-bootstrap:23:in `load'
from /usr/local/bin/bosh-bootstrap:23:in `<main>'

cf-bosh mailing list

cf-bosh mailing list

Dr Nic Williams
Stark & Wayne LLC - consultancy for Cloud Foundry users
cell +1 (415) 860-2185
twitter @drnic

cf-bosh mailing list

cf-bosh mailing list

cf-bosh mailing list

Join { to automatically receive all group messages.