Re: error bootstrapping on aws - ami not found


Danny Berger
 

Hi Akhil - make sure you have updated all references in your bosh manifest
to point to us-west-1 (bosh.io examples use us-east-1). It looks like
bosh-init thinks you're trying to work in us-east-1 - it'll use a different
AMI for the us-west-1 region.

Danny

On Sat, Feb 6, 2016 at 11:15 PM, Akhil Arora <
asquare+linuxfoundation(a)fastmail.com> wrote:

Hi

I was trying to bootstrap an environment on AWS following instructions at
[1]. I'm getting an error -

Started installing CPI
Compiling package
'ruby_aws_cpi/a5b66d011ce1b31642ff148ea2c9097af65ff78c'... Finished
(00:00:00)
Compiling package
'bosh_aws_cpi/c5f87aa3c2bd0f821a73ee76ba9f6de5c79e83e9'... Finished
(00:00:00)
Installing packages... Finished (00:01:33)
Rendering job templates... Finished (00:00:00)
Installing job 'aws_cpi'... Finished (00:00:00)
Finished installing CPI (00:01:33)

Starting registry... Finished (00:00:00)
Uploading stemcell 'bosh-aws-xen-hvm-ubuntu-trusty-go_agent/3012'...

Started deploying
Creating VM for instance 'bosh/0' from stemcell 'ami-5728e73c light'...
Failed (00:00:05)
Failed deploying (00:00:05)

[main] 2016/02/06 23:01:47 ERROR - Command 'deploy' failed: Deploying:
Creating instance 'bosh/0': Creating VM: Creating vm with stemcell cid
'ami-5728e73c light': CPI 'create_vm' method responded with error:
CmdError{"type":"Bosh::Clouds::CloudError","message":"could not find AMI
'ami-5728e73c'","ok_to_retry":false}

Command 'deploy' failed:
Deploying:
Creating instance 'bosh/0':
Creating VM:
Creating vm with stemcell cid 'ami-5728e73c light':
CPI 'create_vm' method responded with error:
CmdError{"type":"Bosh::Clouds::CloudError","message":"could not find AMI
'ami-5728e73c'","ok_to_retry":false}

My AWS region is set to us-west-1, could that be the problem? Is this AMI
not available in us-west-1?

Thanks in advance!

[1] http://bosh.io/docs/init-aws.html


--
Danny Berger

Join cf-bosh@lists.cloudfoundry.org to automatically receive all group messages.